summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/pixman_0.32.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/pixman_0.32.6.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/pixman_0.32.6.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/pixman_0.32.6.bb b/meta/recipes-graphics/xorg-lib/pixman_0.32.6.bb
new file mode 100644
index 0000000000..467ba508ee
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/pixman_0.32.6.bb
@@ -0,0 +1,38 @@
1SUMMARY = "Pixman: Pixel Manipulation library"
2
3DESCRIPTION = "Pixman provides a library for manipulating pixel regions \
4-- a set of Y-X banded rectangles, image compositing using the \
5Porter/Duff model and implicit mask generation for geometric primitives \
6including trapezoids, triangles, and rectangles."
7
8require xorg-lib-common.inc
9
10LICENSE = "MIT & MIT-style & PD"
11LIC_FILES_CHKSUM = "file://COPYING;md5=14096c769ae0cbb5fcb94ec468be11b3 \
12 file://pixman/pixman-matrix.c;endline=25;md5=ba6e8769bfaaee2c41698755af04c4be \
13 file://pixman/pixman-arm-neon-asm.h;endline=24;md5=9a9cc1e51abbf1da58f4d9528ec9d49b \
14 "
15DEPENDS += "zlib libpng"
16BBCLASSEXTEND = "native nativesdk"
17
18PE = "1"
19
20IWMMXT = "--disable-arm-iwmmxt"
21LOONGSON_MMI = "--disable-loongson-mmi"
22NEON = " --disable-arm-neon "
23NEON_class-nativesdk = " --disable-arm-neon "
24NEON_armv7a = " "
25NEON_armv7a-vfp-neon = " "
26
27EXTRA_OECONF = "--disable-gtk ${IWMMXT} ${LOONGSON_MMI} ${NEON}"
28EXTRA_OECONF_class-native = "--disable-gtk"
29
30SRC_URI += "\
31 file://0001-ARM-qemu-related-workarounds-in-cpu-features-detecti.patch \
32 file://mips-export-revert.patch \
33"
34
35SRC_URI[md5sum] = "8a9e8f14743a39cf303803f369c1f344"
36SRC_URI[sha256sum] = "201fc0d7d6bc0017496f2bd27b3ca14224aea0df6b624c5ee2dc0307a4ff14a4"
37
38REQUIRED_DISTRO_FEATURES = ""