summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/libxt_1.1.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/libxt_1.1.4.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/libxt_1.1.4.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libxt_1.1.4.bb b/meta/recipes-graphics/xorg-lib/libxt_1.1.4.bb
new file mode 100644
index 0000000000..9c1aaa4370
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libxt_1.1.4.bb
@@ -0,0 +1,44 @@
1SUMMARY = "Xt: X Toolkit Intrinsics library"
2
3DESCRIPTION = "The Intrinsics are a programming library tailored to the \
4special requirements of user interface construction within a network \
5window system, specifically the X Window System. The Intrinsics and a \
6widget set make up an X Toolkit. The Intrinsics provide the base \
7mechanism necessary to build a wide variety of interoperating widget \
8sets and application environments. The Intrinsics are a layer on top of \
9Xlib, the C Library X Interface. They extend the fundamental \
10abstractions provided by the X Window System while still remaining \
11independent of any particular user interface policy or style."
12
13require xorg-lib-common.inc
14
15LICENSE = "MIT & MIT-style"
16LIC_FILES_CHKSUM = "file://COPYING;md5=6565b1e0094ea1caae0971cc4035f343"
17
18
19DEPENDS += "util-linux libxcb libsm virtual/libx11 kbproto libxdmcp"
20PROVIDES = "xt"
21
22PE = "1"
23
24XORG_PN = "libXt"
25
26SRC_URI += "file://libxt_fix_for_x32.patch"
27
28BBCLASSEXTEND = "native"
29
30EXTRA_OECONF += "--disable-xkb"
31
32do_compile() {
33 (
34 unset CC LD CXX CCLD CFLAGS
35 oe_runmake -C util 'XT_CFLAGS=' 'CC=${BUILD_CC}' 'LD=${BUILD_LD}' 'CXX=${BUILD_CXX}' 'CCLD=${BUILD_CCLD}' 'CFLAGS=-D_GNU_SOURCE -I${STAGING_INCDIR_NATIVE} ${BUILD_CFLAGS}' 'LDFLAGS=${BUILD_LDFLAGS}' 'CXXFLAGS=${BUILD_CXXFLAGS}' 'CPPFLAGS=${BUILD_CPPFLAGS}' makestrs
36 )
37 if [ "$?" != "0" ]; then
38 exit 1
39 fi
40 oe_runmake
41}
42
43SRC_URI[md5sum] = "03149823ae57bb02d0cec90d5b97d56c"
44SRC_URI[sha256sum] = "843a97a988f5654872682a4120486d987d853a71651515472f55519ffae2dd57"