summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/libxft_2.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/libxft_2.3.2.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/libxft_2.3.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libxft_2.3.2.bb b/meta/recipes-graphics/xorg-lib/libxft_2.3.2.bb
new file mode 100644
index 0000000000..a967cdc585
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libxft_2.3.2.bb
@@ -0,0 +1,33 @@
1SUMMARY = "XFt: X FreeType libary"
2
3DESCRIPTION = "Xft was designed to provide good support for scalable \
4fonts, and to do so efficiently. Unlike the core fonts system, it \
5supports features such as anti-aliasing and sub-pixel rasterisation. \
6Perhaps more importantly, it gives applications full control over the \
7way glyphs are rendered, making fine typesetting and WYSIWIG display \
8possible. Finally, it allows applications to use fonts that are not \
9installed system-wide for displaying documents with embedded fonts. Xft \
10is not compatible with the core fonts system: usage of Xft requires \
11fairly extensive changes to toolkits (user-interface libraries)."
12
13require xorg-lib-common.inc
14
15LICENSE = "MIT"
16LIC_FILES_CHKSUM = "file://COPYING;md5=90b90b60eb30f65fc9c2673d7cf59e24"
17
18DEPENDS += "virtual/libx11 libxrender freetype fontconfig"
19PROVIDES = "xft"
20
21PE = "1"
22
23SRC_URI[md5sum] = "331b3a2a3a1a78b5b44cfbd43f86fcfe"
24SRC_URI[sha256sum] = "f5a3c824761df351ca91827ac221090943ef28b248573486050de89f4bfcdc4c"
25
26XORG_PN = "libXft"
27
28BBCLASSEXTEND = "native"
29
30python () {
31 if d.getVar('DEBIAN_NAMES', True):
32 d.setVar('PKG_${PN}', '${MLPREFIX}libxft2')
33}