summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-driver/xf86-video-omapfb_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/xorg-driver/xf86-video-omapfb_git.bb')
-rw-r--r--meta/recipes-graphics/xorg-driver/xf86-video-omapfb_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-driver/xf86-video-omapfb_git.bb b/meta/recipes-graphics/xorg-driver/xf86-video-omapfb_git.bb
new file mode 100644
index 0000000000..4ad25389cd
--- /dev/null
+++ b/meta/recipes-graphics/xorg-driver/xf86-video-omapfb_git.bb
@@ -0,0 +1,34 @@
1require xorg-driver-video.inc
2
3SUMMARY = "X.Org X server -- Texas Instruments OMAP framebuffer driver"
4
5DESCRIPTION = "omapfb driver supports the basic Texas Instruments OMAP \
6framebuffer."
7
8LICENSE = "MIT-X & GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=63e2cbac53863f60e2f43343fb34367f"
10DEPENDS += "virtual/libx11"
11
12SRCREV = "28c006c94e57ea71df11ec4fff79d7ffcfc4860f"
13PR = "${INC_PR}.7"
14PV = "0.1.1+gitr${SRCPV}"
15
16SRC_URI = "git://git.pingu.fi/xf86-video-omapfb;protocol=http \
17 file://0001-Revert-Set-a-large-CRTC-upper-limit-to-not-prune-lar.patch \
18 file://0002-Revert-Set-virtual-size-when-configuring-framebuffer.patch \
19 file://0003-force-plain-mode.patch \
20 file://0004-blacklist-tv-out.patch \
21 file://0005-Attempt-to-fix-VRFB.patch \
22 file://0006-omapfb-port-to-new-xserver-video-API.patch \
23 file://0007-always_include_xorg_server.h.patch \
24"
25
26S = "${WORKDIR}/git"
27
28EXTRA_OECONF_armv7a = " --enable-neon "
29CFLAGS += " -I${STAGING_INCDIR}/xorg "
30
31# Use overlay 2 on omap3 to enable other apps to use overlay 1 (e.g. dmai or omapfbplay)
32do_compile_prepend_armv7a () {
33 sed -i -e s:fb1:fb2:g ${S}/src/omapfb-xv.c
34}