summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb')
-rw-r--r--meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb b/meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb
new file mode 100644
index 0000000000..562434f16a
--- /dev/null
+++ b/meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Touchscreen calibration program for X11"
2HOMEPAGE = "http://www.freedesktop.org/wiki/Software/xinput_calibrator"
3LICENSE = "MIT-X"
4LIC_FILES_CHKSUM = "file://src/calibrator.cpp;endline=22;md5=1bcba08f67cdb56f34021557898e4b5a"
5DEPENDS = "virtual/libx11 libxi"
6
7PV = "0.7.5+git${SRCPV}"
8PR = "r6"
9
10inherit autotools pkgconfig
11
12SRCREV = "c01c5af807cb4b0157b882ab07a893df9a810111"
13SRC_URI = "git://github.com/tias/xinput_calibrator.git \
14 file://30xinput_calibrate.sh \
15 file://Allow-xinput_calibrator_pointercal.sh-to-be-run-as-n.patch"
16
17S = "${WORKDIR}/git"
18
19# force native X11 ui as we don't have gtk+ in DEPENDS
20EXTRA_OECONF += "--with-gui=x11"
21
22do_install_append() {
23 install -d ${D}${bindir}
24 install -m 0755 ${S}/scripts/xinput_calibrator_pointercal.sh ${D}${bindir}/xinput_calibrator_once.sh
25
26 install -d ${D}${sysconfdir}/X11/Xsession.d/
27 install -m 0755 ${WORKDIR}/30xinput_calibrate.sh ${D}${sysconfdir}/X11/Xsession.d/
28
29 install -d ${D}${sysconfdir}/xdg/autostart
30 sed -e 's,^Exec=.*,Exec=${bindir}/xinput_calibrator_once.sh,' ${S}/scripts/xinput_calibrator.desktop > ${D}${sysconfdir}/xdg/autostart/xinput_calibrator.desktop
31}
32
33FILES_${PN} += "${sysconfdir}/xdg/autostart"
34RDEPENDS_${PN} = "xinput formfactor"
35RRECOMMENDS_${PN} = "pointercal-xinput"