summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb')
-rw-r--r--meta/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb b/meta/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb
new file mode 100644
index 0000000000..65348c3762
--- /dev/null
+++ b/meta/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Touchscreen calibration data from xinput-calibrator"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5PR = "r7"
6
7SRC_URI = "file://pointercal.xinput"
8S = "${WORKDIR}"
9
10do_install() {
11 # Only install file if it has a contents
12 if [ -s ${S}/pointercal.xinput ] &&\
13 [ ! -n "$(head -n1 ${S}/pointercal.xinput|grep "replace.*pointercal\.xinput")" ]; then
14 install -d ${D}${sysconfdir}/
15 install -m 0644 ${S}/pointercal.xinput ${D}${sysconfdir}/
16 fi
17}
18
19PACKAGE_ARCH = "${MACHINE_ARCH}"
20CONFFILES_${PN} = "${sysconfdir}/pointercal.xinput"