summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/weston_6.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/wayland/weston_6.0.1.bb')
-rw-r--r--meta/recipes-graphics/wayland/weston_6.0.1.bb109
1 files changed, 109 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/weston_6.0.1.bb b/meta/recipes-graphics/wayland/weston_6.0.1.bb
new file mode 100644
index 0000000000..95b540333e
--- /dev/null
+++ b/meta/recipes-graphics/wayland/weston_6.0.1.bb
@@ -0,0 +1,109 @@
1SUMMARY = "Weston, a Wayland compositor"
2DESCRIPTION = "Weston is the reference implementation of a Wayland compositor"
3HOMEPAGE = "http://wayland.freedesktop.org"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d79ee9e66bb0f95d3386a7acae780b70 \
6 file://libweston/compositor.c;endline=27;md5=6c53bbbd99273f4f7c4affa855c33c0a"
7
8SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
9 file://weston.png \
10 file://weston.desktop \
11 file://0001-make-error-portable.patch \
12 file://xwayland.weston-start \
13 file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \
14"
15SRC_URI[md5sum] = "e7b10710ef1eac82258f97bfd41fe534"
16SRC_URI[sha256sum] = "bf2f6d5aae2e11cabb6bd69a76bcf9edb084f8c3e14ca769bea7234a513155b4"
17
18UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html"
19
20inherit autotools pkgconfig useradd distro_features_check
21# depends on virtual/egl
22REQUIRED_DISTRO_FEATURES = "opengl"
23
24DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 jpeg"
25DEPENDS += "wayland wayland-protocols libinput virtual/egl pango wayland-native"
26
27WESTON_MAJOR_VERSION = "${@'.'.join(d.getVar('PV').split('.')[0:1])}"
28
29EXTRA_OECONF = "--enable-setuid-install \
30 --disable-rdp-compositor \
31 --enable-autotools \
32 "
33PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms fbdev wayland egl', '', d)} \
34 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland', '', d)} \
35 ${@bb.utils.filter('DISTRO_FEATURES', 'pam systemd x11', d)} \
36 clients launch"
37#
38# Compositor choices
39#
40# Weston on KMS
41PACKAGECONFIG[kms] = "--enable-drm-compositor,--disable-drm-compositor,drm udev virtual/mesa virtual/libgbm mtdev"
42# Weston on Wayland (nested Weston)
43PACKAGECONFIG[wayland] = "--enable-wayland-compositor,--disable-wayland-compositor,virtual/mesa"
44# Weston on X11
45PACKAGECONFIG[x11] = "--enable-x11-compositor,--disable-x11-compositor,virtual/libx11 libxcb libxcb libxcursor cairo"
46# Headless Weston
47PACKAGECONFIG[headless] = "--enable-headless-compositor,--disable-headless-compositor"
48# Weston on framebuffer
49PACKAGECONFIG[fbdev] = "--enable-fbdev-compositor,--disable-fbdev-compositor,udev mtdev"
50# weston-launch
51PACKAGECONFIG[launch] = "--enable-weston-launch,--disable-weston-launch,drm"
52# VA-API desktop recorder
53PACKAGECONFIG[vaapi] = "--enable-vaapi-recorder,--disable-vaapi-recorder,libva"
54# Weston with EGL support
55PACKAGECONFIG[egl] = "--enable-egl --enable-simple-egl-clients,--disable-egl --disable-simple-egl-clients,virtual/egl"
56# Weston with cairo glesv2 support
57PACKAGECONFIG[cairo-glesv2] = "--with-cairo-glesv2,--with-cairo=image,cairo"
58# Weston with lcms support
59PACKAGECONFIG[lcms] = "--enable-lcms,--disable-lcms,lcms"
60# Weston with webp support
61PACKAGECONFIG[webp] = "--with-webp,--without-webp,libwebp"
62# Weston with systemd-login support
63PACKAGECONFIG[systemd] = "--enable-systemd-login,--disable-systemd-login,systemd dbus"
64# Weston with Xwayland support (requires X11 and Wayland)
65PACKAGECONFIG[xwayland] = "--enable-xwayland,--disable-xwayland"
66# colord CMS support
67PACKAGECONFIG[colord] = "--enable-colord,--disable-colord,colord"
68# Clients support
69PACKAGECONFIG[clients] = "--enable-clients --enable-simple-clients --enable-demo-clients-install,--disable-clients --disable-simple-clients"
70# Weston with PAM support
71PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam"
72
73do_install_append() {
74 # Weston doesn't need the .la files to load modules, so wipe them
75 rm -f ${D}/${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.la
76
77 # If X11, ship a desktop file to launch it
78 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" ]; then
79 install -d ${D}${datadir}/applications
80 install ${WORKDIR}/weston.desktop ${D}${datadir}/applications
81
82 install -d ${D}${datadir}/icons/hicolor/48x48/apps
83 install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps
84 fi
85
86 if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "yes" ]; then
87 install -Dm 644 ${WORKDIR}/xwayland.weston-start ${D}${datadir}/weston-start/xwayland
88 fi
89}
90
91PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', '${PN}-xwayland', '', d)} \
92 libweston-${WESTON_MAJOR_VERSION} ${PN}-examples"
93
94FILES_${PN} = "${bindir}/weston ${bindir}/weston-terminal ${bindir}/weston-info ${bindir}/weston-launch ${bindir}/wcap-decode ${libexecdir} ${libdir}/${BPN}/*.so ${datadir}"
95
96FILES_libweston-${WESTON_MAJOR_VERSION} = "${libdir}/lib*${SOLIBS} ${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.so"
97SUMMARY_libweston-${WESTON_MAJOR_VERSION} = "Helper library for implementing 'wayland window managers'."
98
99FILES_${PN}-examples = "${bindir}/*"
100
101FILES_${PN}-xwayland = "${libdir}/libweston-${WESTON_MAJOR_VERSION}/xwayland.so"
102RDEPENDS_${PN}-xwayland += "xserver-xorg-xwayland"
103
104RDEPENDS_${PN} += "xkeyboard-config"
105RRECOMMENDS_${PN} = "weston-conf liberation-fonts"
106RRECOMMENDS_${PN}-dev += "wayland-protocols"
107
108USERADD_PACKAGES = "${PN}"
109GROUPADD_PARAM_${PN} = "--system weston-launch"