diff options
Diffstat (limited to 'meta/recipes-graphics/wayland/weston_5.0.0.bb')
-rw-r--r-- | meta/recipes-graphics/wayland/weston_5.0.0.bb | 114 |
1 files changed, 114 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/weston_5.0.0.bb b/meta/recipes-graphics/wayland/weston_5.0.0.bb new file mode 100644 index 0000000000..299408b201 --- /dev/null +++ b/meta/recipes-graphics/wayland/weston_5.0.0.bb | |||
@@ -0,0 +1,114 @@ | |||
1 | SUMMARY = "Weston, a Wayland compositor" | ||
2 | DESCRIPTION = "Weston is the reference implementation of a Wayland compositor" | ||
3 | HOMEPAGE = "http://wayland.freedesktop.org" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d79ee9e66bb0f95d3386a7acae780b70 \ | ||
6 | file://libweston/compositor.c;endline=27;md5=6c53bbbd99273f4f7c4affa855c33c0a" | ||
7 | |||
8 | SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \ | ||
9 | file://weston.png \ | ||
10 | file://weston.desktop \ | ||
11 | file://0001-make-error-portable.patch \ | ||
12 | file://xwayland.weston-start \ | ||
13 | file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \ | ||
14 | " | ||
15 | SRC_URI[md5sum] = "752a04ce3c65af4884cfac4e57231bdb" | ||
16 | SRC_URI[sha256sum] = "15a23423bcfa45e31e1dedc0cd524ba71e2930df174fde9c99b71a537c4e4caf" | ||
17 | |||
18 | UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html" | ||
19 | |||
20 | inherit autotools pkgconfig useradd distro_features_check | ||
21 | # depends on virtual/egl | ||
22 | REQUIRED_DISTRO_FEATURES = "opengl" | ||
23 | |||
24 | DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 jpeg" | ||
25 | DEPENDS += "wayland wayland-protocols libinput virtual/egl pango wayland-native" | ||
26 | |||
27 | WESTON_MAJOR_VERSION = "${@'.'.join(d.getVar('PV').split('.')[0:1])}" | ||
28 | |||
29 | EXTRA_OECONF = "--enable-setuid-install \ | ||
30 | --disable-rdp-compositor \ | ||
31 | " | ||
32 | EXTRA_OECONF_append_qemux86 = "\ | ||
33 | WESTON_NATIVE_BACKEND=fbdev-backend.so \ | ||
34 | " | ||
35 | EXTRA_OECONF_append_qemux86-64 = "\ | ||
36 | WESTON_NATIVE_BACKEND=fbdev-backend.so \ | ||
37 | " | ||
38 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms fbdev wayland egl', '', d)} \ | ||
39 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland', '', d)} \ | ||
40 | ${@bb.utils.filter('DISTRO_FEATURES', 'pam systemd x11', d)} \ | ||
41 | clients launch" | ||
42 | # | ||
43 | # Compositor choices | ||
44 | # | ||
45 | # Weston on KMS | ||
46 | PACKAGECONFIG[kms] = "--enable-drm-compositor,--disable-drm-compositor,drm udev virtual/mesa virtual/libgbm mtdev" | ||
47 | # Weston on Wayland (nested Weston) | ||
48 | PACKAGECONFIG[wayland] = "--enable-wayland-compositor,--disable-wayland-compositor,virtual/mesa" | ||
49 | # Weston on X11 | ||
50 | PACKAGECONFIG[x11] = "--enable-x11-compositor,--disable-x11-compositor,virtual/libx11 libxcb libxcb libxcursor cairo" | ||
51 | # Headless Weston | ||
52 | PACKAGECONFIG[headless] = "--enable-headless-compositor,--disable-headless-compositor" | ||
53 | # Weston on framebuffer | ||
54 | PACKAGECONFIG[fbdev] = "--enable-fbdev-compositor,--disable-fbdev-compositor,udev mtdev" | ||
55 | # weston-launch | ||
56 | PACKAGECONFIG[launch] = "--enable-weston-launch,--disable-weston-launch,drm" | ||
57 | # VA-API desktop recorder | ||
58 | PACKAGECONFIG[vaapi] = "--enable-vaapi-recorder,--disable-vaapi-recorder,libva" | ||
59 | # Weston with EGL support | ||
60 | PACKAGECONFIG[egl] = "--enable-egl --enable-simple-egl-clients,--disable-egl --disable-simple-egl-clients,virtual/egl" | ||
61 | # Weston with cairo glesv2 support | ||
62 | PACKAGECONFIG[cairo-glesv2] = "--with-cairo-glesv2,--with-cairo=image,cairo" | ||
63 | # Weston with lcms support | ||
64 | PACKAGECONFIG[lcms] = "--enable-lcms,--disable-lcms,lcms" | ||
65 | # Weston with webp support | ||
66 | PACKAGECONFIG[webp] = "--with-webp,--without-webp,libwebp" | ||
67 | # Weston with systemd-login support | ||
68 | PACKAGECONFIG[systemd] = "--enable-systemd-login,--disable-systemd-login,systemd dbus" | ||
69 | # Weston with Xwayland support (requires X11 and Wayland) | ||
70 | PACKAGECONFIG[xwayland] = "--enable-xwayland,--disable-xwayland" | ||
71 | # colord CMS support | ||
72 | PACKAGECONFIG[colord] = "--enable-colord,--disable-colord,colord" | ||
73 | # Clients support | ||
74 | PACKAGECONFIG[clients] = "--enable-clients --enable-simple-clients --enable-demo-clients-install,--disable-clients --disable-simple-clients" | ||
75 | # Weston with PAM support | ||
76 | PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam" | ||
77 | |||
78 | do_install_append() { | ||
79 | # Weston doesn't need the .la files to load modules, so wipe them | ||
80 | rm -f ${D}/${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.la | ||
81 | |||
82 | # If X11, ship a desktop file to launch it | ||
83 | if [ "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" ]; then | ||
84 | install -d ${D}${datadir}/applications | ||
85 | install ${WORKDIR}/weston.desktop ${D}${datadir}/applications | ||
86 | |||
87 | install -d ${D}${datadir}/icons/hicolor/48x48/apps | ||
88 | install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps | ||
89 | fi | ||
90 | |||
91 | if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "yes" ]; then | ||
92 | install -Dm 644 ${WORKDIR}/xwayland.weston-start ${D}${datadir}/weston-start/xwayland | ||
93 | fi | ||
94 | } | ||
95 | |||
96 | PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', '${PN}-xwayland', '', d)} \ | ||
97 | libweston-${WESTON_MAJOR_VERSION} ${PN}-examples" | ||
98 | |||
99 | FILES_${PN} = "${bindir}/weston ${bindir}/weston-terminal ${bindir}/weston-info ${bindir}/weston-launch ${bindir}/wcap-decode ${libexecdir} ${libdir}/${BPN}/*.so ${datadir}" | ||
100 | |||
101 | FILES_libweston-${WESTON_MAJOR_VERSION} = "${libdir}/lib*${SOLIBS} ${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.so" | ||
102 | SUMMARY_libweston-${WESTON_MAJOR_VERSION} = "Helper library for implementing 'wayland window managers'." | ||
103 | |||
104 | FILES_${PN}-examples = "${bindir}/*" | ||
105 | |||
106 | FILES_${PN}-xwayland = "${libdir}/libweston-${WESTON_MAJOR_VERSION}/xwayland.so" | ||
107 | RDEPENDS_${PN}-xwayland += "xserver-xorg-xwayland" | ||
108 | |||
109 | RDEPENDS_${PN} += "xkeyboard-config" | ||
110 | RRECOMMENDS_${PN} = "liberation-fonts" | ||
111 | RRECOMMENDS_${PN}-dev += "wayland-protocols" | ||
112 | |||
113 | USERADD_PACKAGES = "${PN}" | ||
114 | GROUPADD_PARAM_${PN} = "--system weston-launch" | ||