diff options
Diffstat (limited to 'meta/recipes-graphics/wayland/weston_1.6.0.bb')
-rw-r--r-- | meta/recipes-graphics/wayland/weston_1.6.0.bb | 89 |
1 files changed, 89 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/weston_1.6.0.bb b/meta/recipes-graphics/wayland/weston_1.6.0.bb new file mode 100644 index 0000000000..efbbbe0369 --- /dev/null +++ b/meta/recipes-graphics/wayland/weston_1.6.0.bb | |||
@@ -0,0 +1,89 @@ | |||
1 | SUMMARY = "Weston, a Wayland compositor" | ||
2 | DESCRIPTION = "Weston is the reference implementation of a Wayland compositor" | ||
3 | HOMEPAGE = "http://wayland.freedesktop.org" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=275efac2559a224527bd4fd593d38466 \ | ||
6 | file://src/compositor.c;endline=23;md5=aa98a8db03480fe7d500d0b1f4b8850c" | ||
7 | |||
8 | SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \ | ||
9 | file://weston.png \ | ||
10 | file://weston.desktop \ | ||
11 | file://disable-wayland-scanner-pkg-check.patch \ | ||
12 | file://make-lcms-explicitly-configurable.patch \ | ||
13 | file://make-libwebp-explicitly-configurable.patch \ | ||
14 | " | ||
15 | SRC_URI[md5sum] = "c60ce9dde99a089db0539d8f6b557827" | ||
16 | SRC_URI[sha256sum] = "dc3ea5d13bbf025fabc006216c5ddc0d80d5f4ebe778912b8c4d1d4acaaa614d" | ||
17 | |||
18 | inherit autotools pkgconfig useradd | ||
19 | |||
20 | DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 jpeg" | ||
21 | DEPENDS += "wayland virtual/egl pango" | ||
22 | |||
23 | EXTRA_OECONF = "--enable-setuid-install \ | ||
24 | --disable-xwayland \ | ||
25 | --enable-simple-clients \ | ||
26 | --enable-clients \ | ||
27 | --enable-demo-clients-install \ | ||
28 | --disable-libunwind \ | ||
29 | --disable-rpi-compositor \ | ||
30 | --disable-rdp-compositor \ | ||
31 | " | ||
32 | |||
33 | |||
34 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms fbdev wayland egl', '', d)} \ | ||
35 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \ | ||
36 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'launch', '', d)} \ | ||
37 | " | ||
38 | # | ||
39 | # Compositor choices | ||
40 | # | ||
41 | # Weston on KMS | ||
42 | PACKAGECONFIG[kms] = "--enable-drm-compositor,--disable-drm-compositor,drm udev virtual/mesa mtdev" | ||
43 | # Weston on Wayland (nested Weston) | ||
44 | PACKAGECONFIG[wayland] = "--enable-wayland-compositor,--disable-wayland-compositor,virtual/mesa" | ||
45 | # Weston on X11 | ||
46 | PACKAGECONFIG[x11] = "--enable-x11-compositor,--disable-x11-compositor,virtual/libx11 libxcb libxcb libxcursor cairo" | ||
47 | # Headless Weston | ||
48 | PACKAGECONFIG[headless] = "--enable-headless-compositor,--disable-headless-compositor" | ||
49 | # Weston on framebuffer | ||
50 | PACKAGECONFIG[fbdev] = "--enable-fbdev-compositor,--disable-fbdev-compositor,udev mtdev" | ||
51 | # weston-launch | ||
52 | PACKAGECONFIG[launch] = "--enable-weston-launch,--disable-weston-launch,libpam drm" | ||
53 | # VA-API desktop recorder | ||
54 | PACKAGECONFIG[vaapi] = "--enable-vaapi-recorder,--disable-vaapi-recorder,libva" | ||
55 | # Weston with EGL support | ||
56 | PACKAGECONFIG[egl] = "--enable-egl --enable-simple-egl-clients,--disable-egl --disable-simple-egl-clients,virtual/egl" | ||
57 | # Weston with cairo glesv2 support | ||
58 | PACKAGECONFIG[cairo-glesv2] = "--with-cairo-glesv2,--with-cairo=image,cairo" | ||
59 | # Weston with lcms support | ||
60 | PACKAGECONFIG[lcms] = "--enable-lcms,--disable-lcms,lcms" | ||
61 | # Weston with webp support | ||
62 | PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp" | ||
63 | # Weston with libinput backend | ||
64 | PACKAGECONFIG[libinput] = "--enable-libinput-backend,--disable-libinput-backend,libinput" | ||
65 | |||
66 | do_install_append() { | ||
67 | # Weston doesn't need the .la files to load modules, so wipe them | ||
68 | rm -f ${D}/${libdir}/weston/*.la | ||
69 | |||
70 | # If X11, ship a desktop file to launch it | ||
71 | if [ "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" = "x11" ]; then | ||
72 | install -d ${D}${datadir}/applications | ||
73 | install ${WORKDIR}/weston.desktop ${D}${datadir}/applications | ||
74 | |||
75 | install -d ${D}${datadir}/icons/hicolor/48x48/apps | ||
76 | install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps | ||
77 | fi | ||
78 | } | ||
79 | |||
80 | PACKAGES += "${PN}-examples" | ||
81 | |||
82 | FILES_${PN} = "${bindir}/weston ${bindir}/weston-terminal ${bindir}/weston-info ${bindir}/weston-launch ${bindir}/wcap-decode ${libexecdir} ${datadir}" | ||
83 | FILES_${PN}-examples = "${bindir}/*" | ||
84 | |||
85 | RDEPENDS_${PN} += "xkeyboard-config" | ||
86 | RRECOMMENDS_${PN} = "liberation-fonts" | ||
87 | |||
88 | USERADD_PACKAGES = "${PN}" | ||
89 | GROUPADD_PARAM_${PN} = "--system weston-launch" | ||