summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/weston_1.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/wayland/weston_1.5.0.bb')
-rw-r--r--meta/recipes-graphics/wayland/weston_1.5.0.bb87
1 files changed, 87 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/weston_1.5.0.bb b/meta/recipes-graphics/wayland/weston_1.5.0.bb
new file mode 100644
index 0000000000..4a8584f79a
--- /dev/null
+++ b/meta/recipes-graphics/wayland/weston_1.5.0.bb
@@ -0,0 +1,87 @@
1SUMMARY = "Weston, a Wayland compositor"
2DESCRIPTION = "Weston is the reference implementation of a Wayland compositor"
3HOMEPAGE = "http://wayland.freedesktop.org"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=275efac2559a224527bd4fd593d38466 \
6 file://src/compositor.c;endline=23;md5=aa98a8db03480fe7d500d0b1f4b8850c"
7
8SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
9 file://weston.png \
10 file://weston.desktop \
11 file://disable-wayland-scanner-pkg-check.patch \
12 file://make-lcms-explicitly-configurable.patch \
13 file://make-libwebp-explicitly-configurable.patch \
14"
15SRC_URI[md5sum] = "8eb40d230efc2411f083c20656534780"
16SRC_URI[sha256sum] = "06388ba04ac79aa72d685cc1a8e646ddb2b8cfe11fcc742294f9addac48b7684"
17
18inherit autotools pkgconfig useradd
19
20DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 jpeg"
21DEPENDS += "wayland virtual/egl pango"
22
23EXTRA_OECONF = "--enable-setuid-install \
24 --disable-xwayland \
25 --enable-simple-clients \
26 --enable-clients \
27 --enable-demo-clients-install \
28 --disable-libunwind \
29 --disable-rpi-compositor \
30 --disable-rdp-compositor \
31 "
32
33
34PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms fbdev wayland egl', '', d)} \
35 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
36 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'launch', '', d)} \
37 "
38#
39# Compositor choices
40#
41# Weston on KMS
42PACKAGECONFIG[kms] = "--enable-drm-compositor,--disable-drm-compositor,drm udev virtual/mesa mtdev"
43# Weston on Wayland (nested Weston)
44PACKAGECONFIG[wayland] = "--enable-wayland-compositor,--disable-wayland-compositor,virtual/mesa"
45# Weston on X11
46PACKAGECONFIG[x11] = "--enable-x11-compositor,--disable-x11-compositor,virtual/libx11 libxcb libxcb libxcursor cairo"
47# Headless Weston
48PACKAGECONFIG[headless] = "--enable-headless-compositor,--disable-headless-compositor"
49# Weston on framebuffer
50PACKAGECONFIG[fbdev] = "--enable-fbdev-compositor,--disable-fbdev-compositor,udev mtdev"
51# weston-launch
52PACKAGECONFIG[launch] = "--enable-weston-launch,--disable-weston-launch,libpam drm"
53# VA-API desktop recorder
54PACKAGECONFIG[vaapi] = "--enable-vaapi-recorder,--disable-vaapi-recorder,libva"
55# Weston with EGL support
56PACKAGECONFIG[egl] = "--enable-egl --enable-simple-egl-clients,--disable-egl --disable-simple-egl-clients,virtual/egl"
57# Weston with cairo glesv2 support
58PACKAGECONFIG[cairo-glesv2] = "--with-cairo-glesv2,--with-cairo=image,cairo"
59# Weston with lcms support
60PACKAGECONFIG[lcms] = "--enable-lcms,--disable-lcms,lcms"
61# Weston with webp support
62PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp"
63
64do_install_append() {
65 # Weston doesn't need the .la files to load modules, so wipe them
66 rm -f ${D}/${libdir}/weston/*.la
67
68 # If X11, ship a desktop file to launch it
69 if [ "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" = "x11" ]; then
70 install -d ${D}${datadir}/applications
71 install ${WORKDIR}/weston.desktop ${D}${datadir}/applications
72
73 install -d ${D}${datadir}/icons/hicolor/48x48/apps
74 install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps
75 fi
76}
77
78PACKAGES += "${PN}-examples"
79
80FILES_${PN} = "${bindir}/weston ${bindir}/weston-terminal ${bindir}/weston-info ${bindir}/weston-launch ${bindir}/wcap-decode ${libexecdir} ${datadir}"
81FILES_${PN}-examples = "${bindir}/*"
82
83RDEPENDS_${PN} += "xkeyboard-config"
84RRECOMMENDS_${PN} = "liberation-fonts"
85
86USERADD_PACKAGES = "${PN}"
87GROUPADD_PARAM_${PN} = "--system weston-launch"