diff options
Diffstat (limited to 'meta/recipes-graphics/wayland/weston_1.3.0.bb')
-rw-r--r-- | meta/recipes-graphics/wayland/weston_1.3.0.bb | 80 |
1 files changed, 80 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/weston_1.3.0.bb b/meta/recipes-graphics/wayland/weston_1.3.0.bb new file mode 100644 index 0000000000..eb38ce142f --- /dev/null +++ b/meta/recipes-graphics/wayland/weston_1.3.0.bb | |||
@@ -0,0 +1,80 @@ | |||
1 | SUMMARY = "Weston, a Wayland compositor" | ||
2 | DESCRIPTION = "Weston is the reference implementation of a Wayland compositor" | ||
3 | HOMEPAGE = "http://wayland.freedesktop.org" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=275efac2559a224527bd4fd593d38466 \ | ||
6 | file://src/compositor.c;endline=23;md5=aa98a8db03480fe7d500d0b1f4b8850c" | ||
7 | |||
8 | SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \ | ||
9 | file://weston.png \ | ||
10 | file://weston.desktop" | ||
11 | SRC_URI[md5sum] = "29ad994dd5ea07f52d7bffb24c25d9f7" | ||
12 | SRC_URI[sha256sum] = "8e4f5b4736358b63d83c3252567ba7aa49cc0da9e2e2c30f59ddf635159702a0" | ||
13 | |||
14 | |||
15 | inherit autotools pkgconfig useradd | ||
16 | |||
17 | DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 jpeg" | ||
18 | DEPENDS += "wayland virtual/mesa virtual/egl pango" | ||
19 | |||
20 | EXTRA_OECONF = "--enable-setuid-install \ | ||
21 | --disable-tablet-shell \ | ||
22 | --disable-xwayland \ | ||
23 | --enable-simple-clients \ | ||
24 | --enable-clients \ | ||
25 | --enable-demo-clients \ | ||
26 | --disable-simple-egl-clients \ | ||
27 | --disable-libunwind \ | ||
28 | --disable-rpi-compositor \ | ||
29 | --disable-rdp-compositor" | ||
30 | |||
31 | |||
32 | PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'wayland', 'kms wayland', '', d)} \ | ||
33 | ${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \ | ||
34 | ${@base_contains('DISTRO_FEATURES', 'opengles2', 'gles', '', d)} \ | ||
35 | ${@base_contains('DISTRO_FEATURES', 'pam', 'launch', '', d)} \ | ||
36 | " | ||
37 | # | ||
38 | # Compositor choices | ||
39 | # | ||
40 | # Weston on KMS | ||
41 | PACKAGECONFIG[kms] = "--enable-drm-compositor,--disable-drm-compositor,drm udev mesa mtdev" | ||
42 | # Weston on Wayland (nested Weston) | ||
43 | PACKAGECONFIG[wayland] = "--enable-wayland-compositor,--disable-wayland-compositor,mesa" | ||
44 | # Weston on X11 | ||
45 | PACKAGECONFIG[x11] = "--enable-x11-compositor,--disable-x11-compositor,virtual/libx11 libxcb libxcb libxcursor cairo" | ||
46 | # Headless Weston | ||
47 | PACKAGECONFIG[headless] = "--enable-headless-compositor,--disable-headless-compositor" | ||
48 | # Weston on framebuffer | ||
49 | PACKAGECONFIG[fbdev] = "--enable-fbdev-compositor,--disable-fbdev-compositor,udev mtdev" | ||
50 | # weston-launch | ||
51 | PACKAGECONFIG[launch] = "--enable-weston-launch,--disable-weston-launch,libpam" | ||
52 | # VA-API desktop recorder | ||
53 | PACKAGECONFIG[vaapi] = "--enable-vaapi-recorder,--disable-vaapi-recorder,libva" | ||
54 | |||
55 | do_install_append() { | ||
56 | # Weston doesn't need the .la files to load modules, so wipe them | ||
57 | rm -f ${D}/${libdir}/weston/*.la | ||
58 | |||
59 | for feature in ${DISTRO_FEATURES}; do | ||
60 | # If X11, ship a desktop file to launch it | ||
61 | if [ "$feature" = "x11" ]; then | ||
62 | install -d ${D}${datadir}/applications | ||
63 | install ${WORKDIR}/weston.desktop ${D}${datadir}/applications | ||
64 | |||
65 | install -d ${D}${datadir}/icons/hicolor/48x48/apps | ||
66 | install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps | ||
67 | fi | ||
68 | done | ||
69 | } | ||
70 | |||
71 | PACKAGES += "${PN}-examples" | ||
72 | |||
73 | FILES_${PN} = "${bindir}/weston ${bindir}/weston-terminal ${bindir}/weston-info ${bindir}/weston-launch ${bindir}/wcap-decode ${libexecdir} ${datadir}" | ||
74 | FILES_${PN}-examples = "${bindir}/*" | ||
75 | |||
76 | RDEPENDS_${PN} += "xkeyboard-config" | ||
77 | RRECOMMENDS_${PN} = "liberation-fonts" | ||
78 | |||
79 | USERADD_PACKAGES = "${PN}" | ||
80 | GROUPADD_PARAM_${PN} = "--system weston-launch" | ||