diff options
Diffstat (limited to 'meta/recipes-graphics/wayland/weston_1.1.0.bb')
-rw-r--r-- | meta/recipes-graphics/wayland/weston_1.1.0.bb | 83 |
1 files changed, 0 insertions, 83 deletions
diff --git a/meta/recipes-graphics/wayland/weston_1.1.0.bb b/meta/recipes-graphics/wayland/weston_1.1.0.bb deleted file mode 100644 index 8280bf266f..0000000000 --- a/meta/recipes-graphics/wayland/weston_1.1.0.bb +++ /dev/null | |||
@@ -1,83 +0,0 @@ | |||
1 | SUMMARY = "Weston, a Wayland compositor" | ||
2 | DESCRIPTION = "Weston is the reference implementation of a Wayland compositor" | ||
3 | HOMEPAGE = "http://wayland.freedesktop.org" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=275efac2559a224527bd4fd593d38466 \ | ||
6 | file://src/compositor.c;endline=23;md5=aa98a8db03480fe7d500d0b1f4b8850c" | ||
7 | |||
8 | SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \ | ||
9 | file://install-examples.patch \ | ||
10 | file://weston-launch-shell.patch \ | ||
11 | file://groups.patch \ | ||
12 | file://weston.png \ | ||
13 | file://weston.desktop" | ||
14 | SRC_URI[md5sum] = "dd9f3043fc5228c6bc4e99873fae2254" | ||
15 | SRC_URI[sha256sum] = "e7715d2c731f77a729c994a599ffdaebac1307b2dd9336136706869fa53618b4" | ||
16 | |||
17 | |||
18 | inherit autotools pkgconfig useradd | ||
19 | |||
20 | DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 jpeg" | ||
21 | DEPENDS += "wayland virtual/mesa virtual/egl pango" | ||
22 | |||
23 | EXTRA_OECONF = "--disable-android-compositor \ | ||
24 | --enable-setuid-install \ | ||
25 | --disable-tablet-shell \ | ||
26 | --disable-xwayland \ | ||
27 | --enable-simple-clients \ | ||
28 | --enable-clients \ | ||
29 | --disable-simple-egl-clients \ | ||
30 | --disable-libunwind \ | ||
31 | --disable-rpi-compositor \ | ||
32 | --disable-rdp-compositor" | ||
33 | |||
34 | |||
35 | PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'wayland', 'kms wayland', '', d)} \ | ||
36 | ${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \ | ||
37 | ${@base_contains('DISTRO_FEATURES', 'opengles2', 'gles', '', d)} \ | ||
38 | ${@base_contains('DISTRO_FEATURES', 'pam', 'launch', '', d)} \ | ||
39 | " | ||
40 | # | ||
41 | # Compositor choices | ||
42 | # | ||
43 | # Weston on KMS | ||
44 | PACKAGECONFIG[kms] = "--enable-drm-compositor,--disable-drm-compositor,drm udev mesa mtdev" | ||
45 | # Weston on Wayland (nested Weston) | ||
46 | PACKAGECONFIG[wayland] = "--enable-wayland-compositor,--disable-wayland-compositor,mesa" | ||
47 | # Weston on X11 | ||
48 | PACKAGECONFIG[x11] = "--enable-x11-compositor,--disable-x11-compositor,virtual/libx11 libxcb libxcb libxcursor cairo" | ||
49 | # Headless Weston | ||
50 | PACKAGECONFIG[headless] = "--enable-headless-compositor,--disable-headless-compositor" | ||
51 | # Weston on framebuffer | ||
52 | PACKAGECONFIG[fbdev] = "--enable-fbdev-compositor,--disable-fbdev-compositor,udev mtdev" | ||
53 | # weston-launch | ||
54 | PACKAGECONFIG[launch] = "--enable-weston-launch,--disable-weston-launch,libpam" | ||
55 | # Use cairo-gl or cairo-glesv2 | ||
56 | PACKAGECONFIG[gles] = "--with-cairo-glesv2,,virtual/libgles2" | ||
57 | |||
58 | do_install_append() { | ||
59 | # Weston doesn't need the .la files to load modules, so wipe them | ||
60 | rm -f ${D}/${libdir}/weston/*.la | ||
61 | |||
62 | for feature in ${DISTRO_FEATURES}; do | ||
63 | # If X11, ship a desktop file to launch it | ||
64 | if [ "$feature" = "x11" ]; then | ||
65 | install -d ${D}${datadir}/applications | ||
66 | install ${WORKDIR}/weston.desktop ${D}${datadir}/applications | ||
67 | |||
68 | install -d ${D}${datadir}/icons/hicolor/48x48/apps | ||
69 | install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps | ||
70 | fi | ||
71 | done | ||
72 | } | ||
73 | |||
74 | PACKAGES += "${PN}-examples" | ||
75 | |||
76 | FILES_${PN} = "${bindir}/weston* ${bindir}/wcap-decode ${libexecdir} ${datadir}" | ||
77 | FILES_${PN}-examples = "${bindir}/*" | ||
78 | |||
79 | RDEPENDS_${PN} += "xkeyboard-config" | ||
80 | RRECOMMENDS_${PN} = "liberation-fonts" | ||
81 | |||
82 | USERADD_PACKAGES = "${PN}" | ||
83 | GROUPADD_PARAM_${PN} = "--system weston-launch" | ||