summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/weston-init.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/wayland/weston-init.bb')
-rw-r--r--meta/recipes-graphics/wayland/weston-init.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/weston-init.bb b/meta/recipes-graphics/wayland/weston-init.bb
new file mode 100644
index 0000000000..38b78bcd02
--- /dev/null
+++ b/meta/recipes-graphics/wayland/weston-init.bb
@@ -0,0 +1,19 @@
1SUMMARY = "Startup script for the Weston Wayland compositor"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
4
5SRC_URI = "file://init"
6
7S = "${WORKDIR}"
8
9do_install() {
10 install -d ${D}/${sysconfdir}/init.d
11 install -m755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/weston
12}
13
14inherit allarch update-rc.d
15
16RDEPENDS_${PN} = "weston kbd"
17
18INITSCRIPT_NAME = "weston"
19INITSCRIPT_PARAMS = "start 9 5 2 . stop 20 0 1 6 ."