summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/wayland_1.8.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/wayland/wayland_1.8.1.bb')
-rw-r--r--meta/recipes-graphics/wayland/wayland_1.8.1.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/meta/recipes-graphics/wayland/wayland_1.8.1.bb b/meta/recipes-graphics/wayland/wayland_1.8.1.bb
index 5b367453cc..ac631af1fb 100644
--- a/meta/recipes-graphics/wayland/wayland_1.8.1.bb
+++ b/meta/recipes-graphics/wayland/wayland_1.8.1.bb
@@ -10,14 +10,15 @@ LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=1d4476a7d98dd5691c53d4d43a510c72 \ 10LIC_FILES_CHKSUM = "file://COPYING;md5=1d4476a7d98dd5691c53d4d43a510c72 \
11 file://src/wayland-server.c;endline=21;md5=079ae21dbf98ada52ec23744851b0a5c" 11 file://src/wayland-server.c;endline=21;md5=079ae21dbf98ada52ec23744851b0a5c"
12 12
13SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz" 13SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
14 file://always-build-scanner.patch"
14SRC_URI[md5sum] = "6e877877c3e04cfb865cfcd0733c9ab1" 15SRC_URI[md5sum] = "6e877877c3e04cfb865cfcd0733c9ab1"
15SRC_URI[sha256sum] = "f17c938d1c24fd0a10f650a623a2775d329db3168b5732e498b08388ec776fc8" 16SRC_URI[sha256sum] = "f17c938d1c24fd0a10f650a623a2775d329db3168b5732e498b08388ec776fc8"
16 17
17SRC_URI_append_class-native = " \ 18SRC_URI_append_class-native = " \
18 file://disable-macro-checks-not-used-for-scanner.patch \ 19 file://disable-macro-checks-not-used-for-scanner.patch \
19 " 20 "
20EXTRA_OECONF_class-native = "--disable-documentation --enable-scanner" 21EXTRA_OECONF_class-native = "--disable-documentation"
21 22
22inherit autotools pkgconfig 23inherit autotools pkgconfig
23 24
@@ -26,7 +27,7 @@ BBCLASSEXTEND = "native"
26 27
27DEPENDS = "expat libffi wayland-native" 28DEPENDS = "expat libffi wayland-native"
28 29
29EXTRA_OECONF = "--disable-documentation --disable-scanner" 30EXTRA_OECONF = "--disable-documentation --with-host-scanner"
30 31
31# Wayland installs a M4 macro for other projects to use, which uses the target 32# Wayland installs a M4 macro for other projects to use, which uses the target
32# pkg-config to find files. Replace pkg-config with pkg-config-native. 33# pkg-config to find files. Replace pkg-config with pkg-config-native.
@@ -40,3 +41,6 @@ sysroot_stage_all_append_class-target () {
40 rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4 41 rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4
41 cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/ 42 cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
42} 43}
44
45FILES_${PN} = "${libdir}/*${SOLIBS}"
46FILES_${PN}-dev += "${bindir} ${datadir}/wayland"