summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/wayland_1.6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/wayland/wayland_1.6.0.bb')
-rw-r--r--meta/recipes-graphics/wayland/wayland_1.6.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/wayland_1.6.0.bb b/meta/recipes-graphics/wayland/wayland_1.6.0.bb
new file mode 100644
index 0000000000..cf3c094634
--- /dev/null
+++ b/meta/recipes-graphics/wayland/wayland_1.6.0.bb
@@ -0,0 +1,41 @@
1SUMMARY = "Wayland, a protocol between a compositor and clients"
2DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \
3as well as a C library implementation of that protocol. The compositor can be \
4a standalone display server running on Linux kernel modesetting and evdev \
5input devices, an X application, or a wayland client itself. The clients can \
6be traditional applications, X servers (rootless or fullscreen) or other \
7display servers."
8HOMEPAGE = "http://wayland.freedesktop.org"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=1d4476a7d98dd5691c53d4d43a510c72 \
11 file://src/wayland-server.c;endline=21;md5=079ae21dbf98ada52ec23744851b0a5c"
12
13SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
14SRC_URI[md5sum] = "d34c141c975084e4fb668e77b38f840e"
15SRC_URI[sha256sum] = "a7d5102dcf53d08c059d24bc62de491d7cd482070abeb6737a20d0d86ba6fc7f"
16SRC_URI_append_class-native = " \
17 file://disable-macro-checks-not-used-for-scanner.patch \
18 "
19EXTRA_OECONF_class-native = "--disable-documentation --enable-scanner"
20
21inherit autotools pkgconfig
22
23# We need wayland-native for the wayland-scanner utility
24BBCLASSEXTEND = "native"
25
26DEPENDS_class-native = "expat-native libffi-native"
27DEPENDS = "expat libffi wayland-native"
28
29EXTRA_OECONF = "--disable-documentation --disable-scanner"
30
31# Wayland installs a M4 macro for other projects to use, which uses the target
32# pkg-config to find files. Replace pkg-config with pkg-config-native.
33do_install_append_class-native() {
34 sed -e 's,PKG_CHECK_MODULES(.*),,g' \
35 -e 's,$PKG_CONFIG,pkg-config-native,g' \
36 -i ${D}/${datadir}/aclocal/wayland-scanner.m4
37}
38
39sysroot_stage_all_append_class-target () {
40 cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
41}