summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/wayland_1.19.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/wayland/wayland_1.19.0.bb')
-rw-r--r--meta/recipes-graphics/wayland/wayland_1.19.0.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-graphics/wayland/wayland_1.19.0.bb b/meta/recipes-graphics/wayland/wayland_1.19.0.bb
index 0fda80ccae..d6e468497d 100644
--- a/meta/recipes-graphics/wayland/wayland_1.19.0.bb
+++ b/meta/recipes-graphics/wayland/wayland_1.19.0.bb
@@ -28,11 +28,11 @@ PACKAGECONFIG ??= "dtd-validation"
28PACKAGECONFIG[dtd-validation] = "-Ddtd_validation=true,-Ddtd_validation=false,libxml2,," 28PACKAGECONFIG[dtd-validation] = "-Ddtd_validation=true,-Ddtd_validation=false,libxml2,,"
29 29
30EXTRA_OEMESON = "-Ddocumentation=false" 30EXTRA_OEMESON = "-Ddocumentation=false"
31EXTRA_OEMESON_class-native = "-Ddocumentation=false -Dlibraries=false" 31EXTRA_OEMESON:class-native = "-Ddocumentation=false -Dlibraries=false"
32 32
33# Wayland installs a M4 macro for other projects to use, which uses the target 33# Wayland installs a M4 macro for other projects to use, which uses the target
34# pkg-config to find files. Replace pkg-config with pkg-config-native. 34# pkg-config to find files. Replace pkg-config with pkg-config-native.
35do_install_append_class-native() { 35do_install:append:class-native() {
36 sed -e 's,PKG_CHECK_MODULES(.*),,g' \ 36 sed -e 's,PKG_CHECK_MODULES(.*),,g' \
37 -e 's,$PKG_CONFIG,pkg-config-native,g' \ 37 -e 's,$PKG_CONFIG,pkg-config-native,g' \
38 -i ${D}/${datadir}/aclocal/wayland-scanner.m4 38 -i ${D}/${datadir}/aclocal/wayland-scanner.m4
@@ -47,16 +47,16 @@ do_install_ptest() {
47 cp -rf ${S}/egl/wayland-egl-symbols-check ${D}${PTEST_PATH}/tests/ 47 cp -rf ${S}/egl/wayland-egl-symbols-check ${D}${PTEST_PATH}/tests/
48} 48}
49 49
50sysroot_stage_all_append_class-target () { 50sysroot_stage_all:append:class-target () {
51 rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4 51 rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4
52 cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/ 52 cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
53} 53}
54 54
55PACKAGES += "${PN}-tools" 55PACKAGES += "${PN}-tools"
56 56
57FILES_${PN} = "${libdir}/*${SOLIBS}" 57FILES:${PN} = "${libdir}/*${SOLIBS}"
58FILES_${PN}-tools += "${bindir} ${datadir}/wayland" 58FILES:${PN}-tools += "${bindir} ${datadir}/wayland"
59 59
60BBCLASSEXTEND = "native nativesdk" 60BBCLASSEXTEND = "native nativesdk"
61 61
62RDEPENDS_${PN}-ptest += "binutils sed ${PN}-tools" 62RDEPENDS:${PN}-ptest += "binutils sed ${PN}-tools"