summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/wayland_1.18.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/wayland/wayland_1.18.0.bb')
-rw-r--r--meta/recipes-graphics/wayland/wayland_1.18.0.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/wayland_1.18.0.bb b/meta/recipes-graphics/wayland/wayland_1.18.0.bb
new file mode 100644
index 0000000000..7a3f075552
--- /dev/null
+++ b/meta/recipes-graphics/wayland/wayland_1.18.0.bb
@@ -0,0 +1,47 @@
1SUMMARY = "Wayland, a protocol between a compositor and clients"
2DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \
3as well as a C library implementation of that protocol. The compositor can be \
4a standalone display server running on Linux kernel modesetting and evdev \
5input devices, an X application, or a wayland client itself. The clients can \
6be traditional applications, X servers (rootless or fullscreen) or other \
7display servers."
8HOMEPAGE = "http://wayland.freedesktop.org"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b31d8f53b6aaf2b4985d7dd7810a70d1 \
11 file://src/wayland-server.c;endline=24;md5=b8e046164a766bb1ede8ba38e9dcd7ce"
12
13DEPENDS = "expat libffi wayland-native"
14
15SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
16 file://fixpathinpcfiles.patch \
17 "
18SRC_URI[md5sum] = "23317697b6e3ff2e1ac8c5ba3ed57b65"
19SRC_URI[sha256sum] = "4675a79f091020817a98fd0484e7208c8762242266967f55a67776936c2e294d"
20
21UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html"
22
23inherit autotools pkgconfig
24
25PACKAGECONFIG ??= "dtd-validation"
26PACKAGECONFIG[dtd-validation] = "--enable-dtd-validation,--disable-dtd-validation,libxml2,,"
27
28EXTRA_OECONF = "--disable-documentation --with-host-scanner"
29EXTRA_OECONF_class-native = "--disable-documentation --disable-libraries"
30
31# Wayland installs a M4 macro for other projects to use, which uses the target
32# pkg-config to find files. Replace pkg-config with pkg-config-native.
33do_install_append_class-native() {
34 sed -e 's,PKG_CHECK_MODULES(.*),,g' \
35 -e 's,$PKG_CONFIG,pkg-config-native,g' \
36 -i ${D}/${datadir}/aclocal/wayland-scanner.m4
37}
38
39sysroot_stage_all_append_class-target () {
40 rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4
41 cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
42}
43
44FILES_${PN} = "${libdir}/*${SOLIBS}"
45FILES_${PN}-dev += "${bindir} ${datadir}/wayland"
46
47BBCLASSEXTEND = "native nativesdk"