summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/wayland_1.12.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/wayland/wayland_1.12.0.bb')
-rw-r--r--meta/recipes-graphics/wayland/wayland_1.12.0.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/wayland_1.12.0.bb b/meta/recipes-graphics/wayland/wayland_1.12.0.bb
new file mode 100644
index 0000000000..de261fe9b1
--- /dev/null
+++ b/meta/recipes-graphics/wayland/wayland_1.12.0.bb
@@ -0,0 +1,42 @@
1SUMMARY = "Wayland, a protocol between a compositor and clients"
2DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \
3as well as a C library implementation of that protocol. The compositor can be \
4a standalone display server running on Linux kernel modesetting and evdev \
5input devices, an X application, or a wayland client itself. The clients can \
6be traditional applications, X servers (rootless or fullscreen) or other \
7display servers."
8HOMEPAGE = "http://wayland.freedesktop.org"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b31d8f53b6aaf2b4985d7dd7810a70d1 \
11 file://src/wayland-server.c;endline=24;md5=b8e046164a766bb1ede8ba38e9dcd7ce"
12
13SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
14 "
15SRC_URI[md5sum] = "ee615e2d1e205eec48b02f069327eb96"
16SRC_URI[sha256sum] = "d6b4135cba0188abcb7275513c72dede751d6194f6edc5b82183a3ba8b821ab1"
17
18EXTRA_OECONF_class-native = "--disable-documentation --disable-libraries"
19
20inherit autotools pkgconfig
21
22BBCLASSEXTEND = "native nativesdk"
23
24DEPENDS = "expat libxml2 libffi wayland-native"
25
26EXTRA_OECONF = "--disable-documentation --with-host-scanner"
27
28# Wayland installs a M4 macro for other projects to use, which uses the target
29# pkg-config to find files. Replace pkg-config with pkg-config-native.
30do_install_append_class-native() {
31 sed -e 's,PKG_CHECK_MODULES(.*),,g' \
32 -e 's,$PKG_CONFIG,pkg-config-native,g' \
33 -i ${D}/${datadir}/aclocal/wayland-scanner.m4
34}
35
36sysroot_stage_all_append_class-target () {
37 rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4
38 cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
39}
40
41FILES_${PN} = "${libdir}/*${SOLIBS}"
42FILES_${PN}-dev += "${bindir} ${datadir}/wayland"