summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/wayland_1.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/wayland/wayland_1.1.0.bb')
-rw-r--r--meta/recipes-graphics/wayland/wayland_1.1.0.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/wayland_1.1.0.bb b/meta/recipes-graphics/wayland/wayland_1.1.0.bb
new file mode 100644
index 0000000000..a71402e253
--- /dev/null
+++ b/meta/recipes-graphics/wayland/wayland_1.1.0.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Wayland, a protocol between a compositor and clients"
2DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \
3as well as a C library implementation of that protocol. The compositor can be \
4a standalone display server running on Linux kernel modesetting and evdev \
5input devices, an X application, or a wayland client itself. The clients can \
6be traditional applications, X servers (rootless or fullscreen) or other \
7display servers."
8HOMEPAGE = "http://wayland.freedesktop.org"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=1d4476a7d98dd5691c53d4d43a510c72 \
11 file://src/wayland-server.c;endline=21;md5=079ae21dbf98ada52ec23744851b0a5c"
12
13SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
14SRC_URI[md5sum] = "d2dc9398a83692cafc16eba6e45f85d8"
15SRC_URI[sha256sum] = "2ef587cf1a0e52b6dee44eeb9c288110e8180819abf4e419d247dfe234867a5c"
16
17SRC_URI_append_class-native = " file://just-scanner.patch"
18
19inherit autotools pkgconfig
20
21# We need wayland-native for the wayland-scanner utility
22BBCLASSEXTEND = "native"
23
24DEPENDS_virtclass-native = "expat-native libffi-native"
25DEPENDS = "expat libffi wayland-native"
26
27EXTRA_OECONF_virtclass-native = "--disable-documentation"
28EXTRA_OECONF = "--disable-documentation --disable-scanner"
29
30# Wayland installs a M4 macro for other projects to use. This M4 macro includes
31# a path to a Makefile fragment to get the rules to generate stubs from protocol
32# description files. The paths to the sysroot end up incorrect, so fix them.
33do_configure_append_class-native() {
34 sed -e 's,@prefix@,${STAGING_DIR_NATIVE},g' \
35 -e 's,@exec_prefix@,${STAGING_DIR_NATIVE},g' \
36 -e 's,@bindir@,${STAGING_BINDIR_NATIVE},g' \
37 -e 's,@datarootdir@,${STAGING_DATADIR_NATIVE},g' \
38 ${S}/wayland-scanner.m4.in > ${B}/wayland-scanner.m4
39}