summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/libinput_1.8.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/wayland/libinput_1.8.1.bb')
-rw-r--r--meta/recipes-graphics/wayland/libinput_1.8.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/libinput_1.8.1.bb b/meta/recipes-graphics/wayland/libinput_1.8.1.bb
new file mode 100644
index 0000000000..f75298b899
--- /dev/null
+++ b/meta/recipes-graphics/wayland/libinput_1.8.1.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Library to handle input devices in Wayland compositors"
2HOMEPAGE = "http://www.freedesktop.org/wiki/Software/libinput/"
3SECTION = "libs"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;md5=2184aef38ff137ed33ce9a63b9d1eb8f"
7
8DEPENDS = "libevdev udev mtdev"
9
10SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BP}.tar.xz \
11 file://touchpad-serial-synaptics-need-to-fake-new-touches-on-TRIPLETAP.patch \
12 file://0001-tools-Fix-race-in-autotools-install.patch \
13"
14
15SRC_URI[md5sum] = "8247f0bb67052ffb272c50c3cb9c5998"
16SRC_URI[sha256sum] = "e3590a9037e561a5791c8bd3b34bfd30fad5cacd8cbefc0d75fafe3a41d07147"
17
18inherit autotools pkgconfig lib_package
19
20PACKAGECONFIG ??= ""
21PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
22PACKAGECONFIG[libwacom] = "--enable-libwacom,--disable-libwacom,libwacom"
23PACKAGECONFIG[gui] = "--enable-debug-gui,--disable-debug-gui,cairo gtk+3"
24
25UDEVDIR = "`pkg-config --variable=udevdir udev`"
26
27EXTRA_OECONF += "--with-udev-dir=${UDEVDIR} --disable-documentation --disable-tests"
28
29# package name changed in 1.8.1 upgrade: make sure package upgrades work
30RPROVIDES_${PN} = "libinput"
31RREPLACES_${PN} = "libinput"
32RCONFLICTS_${PN} = "libinput"