summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/libinput_1.15.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/wayland/libinput_1.15.2.bb')
-rw-r--r--meta/recipes-graphics/wayland/libinput_1.15.2.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/libinput_1.15.2.bb b/meta/recipes-graphics/wayland/libinput_1.15.2.bb
new file mode 100644
index 0000000000..810532774e
--- /dev/null
+++ b/meta/recipes-graphics/wayland/libinput_1.15.2.bb
@@ -0,0 +1,40 @@
1SUMMARY = "Library to handle input devices in Wayland compositors"
2DESCRIPTION = "libinput is a library to handle input devices in Wayland \
3compositors and to provide a generic X.Org input driver. It provides \
4device detection, device handling, input device event processing and \
5abstraction so minimize the amount of custom input code compositors need to \
6provide the common set of functionality that users expect."
7HOMEPAGE = "http://www.freedesktop.org/wiki/Software/libinput/"
8SECTION = "libs"
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://COPYING;md5=1f2ea9ebff3a2c6d458faf58492efb63"
12
13DEPENDS = "libevdev udev mtdev"
14
15SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BP}.tar.xz \
16 file://determinism.patch \
17 "
18SRC_URI[md5sum] = "eb6bd2907ad33d53954d70dfb881a643"
19SRC_URI[sha256sum] = "971c3fbfb624f95c911adeb2803c372e4e3647d1b98f278f660051f834597747"
20
21UPSTREAM_CHECK_REGEX = "libinput-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)"
22
23inherit meson pkgconfig lib_package
24
25PACKAGECONFIG ??= ""
26PACKAGECONFIG[libwacom] = "-Dlibwacom=true,-Dlibwacom=false,libwacom"
27PACKAGECONFIG[gui] = "-Ddebug-gui=true,-Ddebug-gui=false,cairo gtk+3"
28
29UDEVDIR = "`pkg-config --variable=udevdir udev`"
30
31EXTRA_OEMESON += "-Dudev-dir=${UDEVDIR} \
32 -Ddocumentation=false \
33 -Dtests=false \
34 -Dzshcompletiondir=no"
35
36# package name changed in 1.8.1 upgrade: make sure package upgrades work
37RPROVIDES_${PN} = "libinput"
38RREPLACES_${PN} = "libinput"
39RCONFLICTS_${PN} = "libinput"
40