summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/vulkan/vulkan-demos_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/vulkan/vulkan-demos_git.bb')
-rw-r--r--meta/recipes-graphics/vulkan/vulkan-demos_git.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-graphics/vulkan/vulkan-demos_git.bb b/meta/recipes-graphics/vulkan/vulkan-demos_git.bb
new file mode 100644
index 0000000000..fcd9e7b7c8
--- /dev/null
+++ b/meta/recipes-graphics/vulkan/vulkan-demos_git.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "Collection of Vulkan examples"
2LICENSE = "MIT"
3DEPENDS = "zlib"
4
5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=dcf473723faabf17baa9b5f2207599d0 \
6 file://triangle/triangle.cpp;endline=12;md5=bccd1bf9cadd9e10086cf7872157e4fa"
7
8SRC_URI = "git://github.com/SaschaWillems/Vulkan.git \
9 file://0001-Support-installing-demos-support-out-of-tree-builds.patch \
10 file://0001-Don-t-build-demos-with-questionably-licensed-data.patch \
11 file://0001-Fix-build-on-x86.patch \
12"
13SRCREV = "18df00c7b4677b0889486e16977857aa987947e2"
14UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for"
15S = "${WORKDIR}/git"
16
17inherit cmake distro_features_check
18DEPENDS = "vulkan assimp"
19
20do_install_append () {
21 # Remove assets that have uncertain licenses
22 rm ${D}${datadir}/vulkan-demos/models/armor/* \
23 ${D}${datadir}/vulkan-demos/models/sibenik/* \
24 ${D}${datadir}/vulkan-demos/models/vulkanscene* \
25 ${D}${datadir}/vulkan-demos/models/plants.dae \
26 ${D}${datadir}/vulkan-demos/textures/texturearray_plants*
27}
28
29EXTRA_OECMAKE = "-DRESOURCE_INSTALL_DIR=${datadir}/vulkan-demos"
30
31ANY_OF_DISTRO_FEATURES = "x11 wayland"
32
33# Can only pick one of [wayland,xcb]
34PACKAGECONFIG = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', 'xcb' ,d)}"
35PACKAGECONFIG[wayland] = "-DUSE_WAYLAND_WSI=ON, -DUSE_WAYLAND_WSI=OFF, wayland"
36PACKAGECONFIG[xcb] = ",,libxcb"