summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb')
-rw-r--r--meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb b/meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb
new file mode 100644
index 0000000000..b2e4cef39d
--- /dev/null
+++ b/meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb
@@ -0,0 +1,38 @@
1SUMMARY = "The Bitstream Vera fonts - TTF Edition"
2DESCRIPTION = "The Bitstream Vera fonts include four monospace and sans \
3faces (normal, oblique, bold, bold oblique) and two serif faces (normal \
4and bold). In addition Fontconfig/Xft2 can artificially oblique the \
5serif faces for you: this loses hinting and distorts the faces slightly, \
6but is visibly different than normal and bold, and reasonably pleasing."
7SECTION = "x11/fonts"
8LICENSE = "BitstreamVera"
9LIC_FILES_CHKSUM = "file://COPYRIGHT.TXT;md5=27d7484b1e18d0ee4ce538644a3f04be"
10PR = "r7"
11
12inherit fontcache
13
14FONT_PACKAGES = "${PN}"
15
16SRC_URI = "${GNOME_MIRROR}/ttf-bitstream-vera/1.10/ttf-bitstream-vera-${PV}.tar.bz2"
17
18do_install () {
19 install -d ${D}${prefix}/share/fonts/ttf/
20 for i in *.ttf; do
21 install -m 644 $i ${D}${prefix}/share/fonts/ttf/${i}
22 done
23
24 # fontconfig ships this too. not sure what to do about it.
25 #install -d ${D}${sysconfdir}/fonts
26 #install -m 644 local.conf ${D}${sysconfdir}/fonts/local.conf
27
28
29 install -d ${D}${prefix}/share/doc/${BPN}/
30 for i in *.TXT; do
31 install -m 644 $i ${D}${prefix}/share/doc/${BPN}/$i
32 done
33}
34
35FILES_${PN} = "/etc ${datadir}/fonts"
36
37SRC_URI[md5sum] = "bb22bd5b4675f5dbe17c6963d8c00ed6"
38SRC_URI[sha256sum] = "db5b27df7bbb318036ebdb75acd3e98f1bd6eb6608fb70a67d478cd243d178dc"