summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb')
-rw-r--r--meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb b/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb
new file mode 100644
index 0000000000..89fa4b211d
--- /dev/null
+++ b/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb
@@ -0,0 +1,38 @@
1SUMMARY = "Liberation(tm) Fonts"
2DESCRIPTION = "The Liberation(tm) Fonts is a font family originally \
3created by Ascender(c) which aims at metric compatibility with \
4Arial, Times New Roman, Courier New."
5HOMEPAGE = "https://fedorahosted.org/liberation-fonts/"
6BUGTRACKER = "https://bugzilla.redhat.com/"
7
8SECTION = "x11/fonts"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
11PR = "r4"
12PE = "1"
13
14inherit fontcache
15
16FONT_PACKAGES = "${PN}"
17
18SRC_URI = "https://fedorahosted.org/releases/l/i/liberation-fonts/liberation-fonts-${PV}.tar.gz \
19 file://30-liberation-aliases.conf"
20
21SRC_URI[md5sum] = "4846797ef0fc70b0cbaede2514677c58"
22SRC_URI[sha256sum] = "0e0d0957c85b758561a3d4aef4ebcd2c39959e5328429d96ae106249d83531a1"
23
24do_install () {
25 install -d ${D}${datadir}/fonts/ttf/
26 for i in *.ttf; do
27 install -m 0644 $i ${D}${prefix}/share/fonts/ttf/${i}
28 done
29
30 install -d ${D}${sysconfdir}/fonts/conf.d/
31 install -m 0644 ${WORKDIR}/30-liberation-aliases.conf ${D}${sysconfdir}/fonts/conf.d/
32
33 install -d ${D}${prefix}/share/doc/${BPN}/
34 install -m 0644 License.txt ${D}${datadir}/doc/${BPN}/
35}
36
37PACKAGES = "${PN}"
38FILES_${PN} += "${sysconfdir} ${datadir}"