summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb')
-rw-r--r--meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb b/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb
new file mode 100644
index 0000000000..6b887e31b6
--- /dev/null
+++ b/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb
@@ -0,0 +1,34 @@
1DESCRIPTION = "The Liberation(tm) Fonts is a font family originally created by Ascender(c) which aims metric compatibility as usage of Arial, Times New Roman, Courier New"
2HOMEPAGE = "https://fedorahosted.org/liberation-fonts/"
3BUGTRACKER = "https://bugzilla.redhat.com/"
4
5SECTION = "x11/fonts"
6PRIORITY = "optional"
7LICENSE = "GPLv2"
8PACKAGE_ARCH = "all"
9RDEPENDS = "fontconfig-utils"
10PE = "1"
11
12SRC_URI = "https://fedorahosted.org/releases/l/i/liberation-fonts/liberation-fonts-${PV}.tar.gz \
13 file://30-liberation-aliases.conf"
14
15do_install () {
16 install -d ${D}${datadir}/fonts/ttf/
17 for i in *.ttf; do
18 install -m 0644 $i ${D}${prefix}/share/fonts/ttf/${i}
19 done
20
21 install -d ${D}${sysconfdir}/fonts/conf.d/
22 install -m 0644 ${WORKDIR}/30-liberation-aliases.conf ${D}${sysconfdir}/fonts/conf.d/
23
24 install -d ${D}${prefix}/share/doc/${PN}/
25 install -m 0644 License.txt ${D}${datadir}/doc/${PN}/
26}
27
28pkg_postinst () {
29#!/bin/sh
30fc-cache
31}
32
33PACKAGES = "${PN}"
34FILES_${PN} += "${sysconfdir} ${datadir}"