summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/tslib/tslib_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/tslib/tslib_1.0.bb')
-rw-r--r--meta/recipes-graphics/tslib/tslib_1.0.bb78
1 files changed, 78 insertions, 0 deletions
diff --git a/meta/recipes-graphics/tslib/tslib_1.0.bb b/meta/recipes-graphics/tslib/tslib_1.0.bb
new file mode 100644
index 0000000000..12c0ace8f8
--- /dev/null
+++ b/meta/recipes-graphics/tslib/tslib_1.0.bb
@@ -0,0 +1,78 @@
1DESCRIPTION = "tslib is a plugin-based flexible touchscreen access library."
2HOMEPAGE = "http://tslib.berlios.de/"
3
4AUTHOR = "Russell King w/ plugins by Chris Larson et. al."
5SECTION = "base"
6LICENSE = "LGPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=f30a9716ef3762e3467a2f62bf790f0a"
8
9PR = "r15"
10
11SRC_URI = "http://download.berlios.de/tslib/tslib-${PV}.tar.bz2 \
12 file://fix_version.patch;patch=1 \
13 file://ts.conf \
14 file://ts.conf-simpad-2.4 \
15 file://ts.conf-collie-2.4 \
16 file://tslib.sh"
17SRC_URI_append_mnci += " file://devfs.patch;patch=1"
18SRC_URI_append_mnci += " file://event1.patch;patch=1"
19
20inherit autotools pkgconfig
21
22EXTRA_OECONF = "--enable-shared --disable-h3600 --enable-input --disable-corgi --disable-collie --disable-mk712 --disable-arctic2 --disable-ucb1x00"
23
24do_install_prepend() {
25 install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf
26}
27
28do_install_append() {
29 install -d ${D}${sysconfdir}/profile.d/
30 install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
31 case ${MACHINE} in
32 collie )
33 install -d ${D}${datadir}/tslib
34 install -m 0644 ${WORKDIR}/ts.conf-collie-2.4 ${D}${datadir}/tslib/
35 ;;
36 simpad )
37 install -d ${D}${datadir}/tslib
38 install -m 0644 ${WORKDIR}/ts.conf-simpad-2.4 ${D}${datadir}/tslib/
39 ;;
40 *)
41 ;;
42 esac
43}
44
45SRC_URI_OVERRIDES_PACKAGE_ARCH = "0"
46
47# People should consider using udev's /dev/input/touchscreen0 symlink
48# instead of detect-stylus
49#RDEPENDS_tslib-conf_weird-machine = "detect-stylus"
50RPROVIDES_tslib-conf = "libts-0.0-conf"
51
52# Machines with machine specific patches
53PACKAGE_ARCH_mnci = "${MACHINE_ARCH}"
54# Machines with machine specific config files (tslib.sh)
55PACKAGE_ARCH_tslib-conf_a780 = "${MACHINE_ARCH}"
56PACKAGE_ARCH_tslib-conf_collie = "${MACHINE_ARCH}"
57PACKAGE_ARCH_tslib-conf_e680 = "${MACHINE_ARCH}"
58PACKAGE_ARCH_tslib-conf_jornada56x = "${MACHINE_ARCH}"
59PACKAGE_ARCH_tslib-conf_jornada6xx = "${MACHINE_ARCH}"
60PACKAGE_ARCH_tslib-conf_jornada7xx = "${MACHINE_ARCH}"
61PACKAGE_ARCH_tslib-conf_netbook-pro = "${MACHINE_ARCH}"
62PACKAGE_ARCH_tslib-conf_omap1610h2 = "${MACHINE_ARCH}"
63PACKAGE_ARCH_tslib-conf_omap5912osk = "${MACHINE_ARCH}"
64PACKAGE_ARCH_tslib-conf_simpad = "${MACHINE_ARCH}"
65
66PACKAGES =+ "tslib-conf tslib-tests tslib-calibrate"
67DEBIAN_NOAUTONAME_tslib-conf = "1"
68DEBIAN_NOAUTONAME_tslib-tests = "1"
69DEBIAN_NOAUTONAME_tslib-calibrate = "1"
70
71RDEPENDS_${PN} = "tslib-conf"
72RRECOMMENDS_${PN} = "pointercal"
73
74FILES_${PN}-dbg += "${libdir}/ts/.debug*"
75FILES_tslib-conf = "${sysconfdir}/ts.conf ${sysconfdir}/profile.d/tslib.sh ${datadir}/tslib"
76FILES_${PN} = "${libdir}/*.so.* ${libdir}/ts/*.so*"
77FILES_tslib-calibrate += "${bindir}/ts_calibrate"
78FILES_tslib-tests = "${bindir}/ts_harvest ${bindir}/ts_print ${bindir}/ts_print_raw ${bindir}/ts_test"