diff options
Diffstat (limited to 'meta/recipes-graphics/spir/spirv-tools_2019.5.bb')
-rw-r--r-- | meta/recipes-graphics/spir/spirv-tools_2019.5.bb | 39 |
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-graphics/spir/spirv-tools_2019.5.bb b/meta/recipes-graphics/spir/spirv-tools_2019.5.bb new file mode 100644 index 0000000000..0b54706974 --- /dev/null +++ b/meta/recipes-graphics/spir/spirv-tools_2019.5.bb | |||
@@ -0,0 +1,39 @@ | |||
1 | SUMMARY = "The SPIR-V Tools project provides an API and commands for \ | ||
2 | processing SPIR-V modules" | ||
3 | DESCRIPTION = "The project includes an assembler, binary module parser, \ | ||
4 | disassembler, validator, and optimizer for SPIR-V." | ||
5 | LICENSE = "Apache-2.0" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | ||
7 | SECTION = "graphics" | ||
8 | |||
9 | S = "${WORKDIR}/git" | ||
10 | DEST_DIR = "${S}/external" | ||
11 | SRC_URI = "git://github.com/KhronosGroup/SPIRV-Tools.git;name=spirv-tools \ | ||
12 | git://github.com/KhronosGroup/SPIRV-Headers.git;name=spirv-headers;destsuffix=${DEST_DIR}/spirv-headers \ | ||
13 | git://github.com/google/effcee.git;name=effcee;destsuffix=${DEST_DIR}/effcee \ | ||
14 | git://github.com/google/re2.git;name=re2;destsuffix=${DEST_DIR}/re2 \ | ||
15 | git://github.com/google/googletest.git;name=googletest;destsuffix=${DEST_DIR}/googletest \ | ||
16 | file://0001-Respect-CMAKE_INSTALL_LIBDIR-in-installed-CMake-file.patch;destsuffix=${DEST_DIR}/effcee \ | ||
17 | file://0001-Avoid-pessimizing-std-move-3124.patch \ | ||
18 | " | ||
19 | SRCREV_spirv-tools = "c413b982c316b14e784f50d941814fc737b55b4a" | ||
20 | SRCREV_spirv-headers = "af64a9e826bf5bb5fcd2434dd71be1e41e922563" | ||
21 | SRCREV_effcee = "cd25ec17e9382f99a895b9ef53ff3c277464d07d" | ||
22 | SRCREV_re2 = "5bd613749fd530b576b890283bfb6bc6ea6246cb" | ||
23 | SRCREV_googletest = "f2fb48c3b3d79a75a88a99fba6576b25d42ec528" | ||
24 | |||
25 | inherit cmake python3native | ||
26 | |||
27 | EXTRA_OECMAKE += "-DSPIRV_WERROR=OFF" | ||
28 | |||
29 | do_install_append() { | ||
30 | install -d ${D}/${includedir}/spirv | ||
31 | install -m 0644 ${DEST_DIR}/spirv-headers/include/spirv/1.2/* ${D}${includedir}/spirv | ||
32 | install -d ${D}/${includedir}/spirv/unified1 | ||
33 | install -m 0644 ${DEST_DIR}/spirv-headers/include/spirv/unified1/* ${D}${includedir}/spirv/unified1 | ||
34 | } | ||
35 | |||
36 | FILES_SOLIBSDEV = "" | ||
37 | FILES_${PN} += "${libdir}/*.so" | ||
38 | |||
39 | BBCLASSEXTEND = "native nativesdk" | ||