diff options
Diffstat (limited to 'meta/recipes-graphics/shaderc/shaderc_2020.4.bb')
-rw-r--r-- | meta/recipes-graphics/shaderc/shaderc_2020.4.bb | 20 |
1 files changed, 5 insertions, 15 deletions
diff --git a/meta/recipes-graphics/shaderc/shaderc_2020.4.bb b/meta/recipes-graphics/shaderc/shaderc_2020.4.bb index e966ed3d77..73aa0ee969 100644 --- a/meta/recipes-graphics/shaderc/shaderc_2020.4.bb +++ b/meta/recipes-graphics/shaderc/shaderc_2020.4.bb | |||
@@ -8,7 +8,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" | |||
8 | 8 | ||
9 | SRCREV = "0dbd899941a43ffd55df527d65128b3b66e75c9c" | 9 | SRCREV = "0dbd899941a43ffd55df527d65128b3b66e75c9c" |
10 | SRC_URI = "git://github.com/google/shaderc.git;protocol=https;branch=main \ | 10 | SRC_URI = "git://github.com/google/shaderc.git;protocol=https;branch=main \ |
11 | file://0001-cmake-de-vendor-libs-and-disable-git-versioning.patch \ | 11 | file://0001-cmake-disable-building-external-dependencies.patch \ |
12 | file://0002-libshaderc_util-fix-glslang-header-file-location.patch \ | ||
13 | file://0003-cmake-add-option-to-skip-build-the-examples.patch \ | ||
12 | " | 14 | " |
13 | UPSTREAM_CHECK_GITTAGREGEX = "^v(?P<pver>\d+(\.\d+)+)$" | 15 | UPSTREAM_CHECK_GITTAGREGEX = "^v(?P<pver>\d+(\.\d+)+)$" |
14 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
@@ -19,21 +21,9 @@ DEPENDS = "spirv-headers spirv-tools glslang" | |||
19 | 21 | ||
20 | EXTRA_OECMAKE = " \ | 22 | EXTRA_OECMAKE = " \ |
21 | -DCMAKE_BUILD_TYPE=Release \ | 23 | -DCMAKE_BUILD_TYPE=Release \ |
24 | -DBUILD_EXTERNAL=OFF \ | ||
22 | -DSHADERC_SKIP_TESTS=ON \ | 25 | -DSHADERC_SKIP_TESTS=ON \ |
23 | -Dglslang_SOURCE_DIR=${STAGING_INCDIR}/glslang \ | 26 | -DSHADERC_SKIP_EXAMPLES=ON \ |
24 | " | 27 | " |
25 | 28 | ||
26 | BBCLASSEXTEND = "native nativesdk" | 29 | BBCLASSEXTEND = "native nativesdk" |
27 | |||
28 | # TODO: probably there is better solution for this. | ||
29 | # I don't know any method for get the version of a receipe in DEPENDS, | ||
30 | # so do this ugly hack | ||
31 | inherit pkgconfig | ||
32 | DEPENDS += "glslang-native" | ||
33 | do_configure_prepend() { | ||
34 | cat <<- EOF > ${S}/glslc/src/build-version.inc | ||
35 | "${PV}\\n" | ||
36 | "$(pkg-config --modversion SPIRV-Tools)\\n" | ||
37 | "$(glslangValidator --version | head -1 | cut -d' ' -f3)\\n" | ||
38 | EOF | ||
39 | } | ||