summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/shaderc/shaderc_2020.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/shaderc/shaderc_2020.3.bb')
-rw-r--r--meta/recipes-graphics/shaderc/shaderc_2020.3.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-graphics/shaderc/shaderc_2020.3.bb b/meta/recipes-graphics/shaderc/shaderc_2020.3.bb
new file mode 100644
index 0000000000..f5edf53caf
--- /dev/null
+++ b/meta/recipes-graphics/shaderc/shaderc_2020.3.bb
@@ -0,0 +1,33 @@
1SUMMARY = "A collection of tools, libraries and tests for shader compilation"
2DESCRIPTION = "The Shaderc library provides an API for compiling GLSL/HLSL \
3source code to SPIRV modules. It has been shipping in the Android NDK since version r12b."
4SECTION = "graphics"
5HOMEPAGE = "https://github.com/google/shaderc"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9SRCREV = "1fce59794079f90ceb091190adbbb5499acd4e95"
10SRC_URI = "git://github.com/google/shaderc.git;protocol=https;branch=main \
11 file://0001-Fix-the-link-order-of-libglslang-and-libHLSL.patch \
12 file://0003-cmake-de-vendor-libs-and-disable-git-versioning.patch \
13 "
14S = "${WORKDIR}/git"
15
16inherit cmake python3native
17
18DEPENDS = "spirv-tools glslang"
19
20EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release -DSHADERC_SKIP_TESTS=ON"
21
22do_configure_prepend() {
23 # TODO: probably there is better solution for this.
24 # I dont know any method for get the version of a receipe in DEPENDS
25 # so do this ugly hack
26 cat <<- EOF > ${S}/glslc/src/build-version.inc
27"${PV}\\n"
28"$(pkg-config --modversion SPIRV-Tools)\\n"
29"$(glslangValidator --version | head -1 | cut -d' ' -f3)\\n"
30EOF
31}
32
33BBCLASSEXTEND = "native nativesdk"