summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/piglit/piglit_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/piglit/piglit_git.bb')
-rw-r--r--meta/recipes-graphics/piglit/piglit_git.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-graphics/piglit/piglit_git.bb b/meta/recipes-graphics/piglit/piglit_git.bb
new file mode 100644
index 0000000000..f468120f80
--- /dev/null
+++ b/meta/recipes-graphics/piglit/piglit_git.bb
@@ -0,0 +1,51 @@
1SUMMARY = "OpenGL driver testing framework"
2LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
4
5SRC_URI = "git://anongit.freedesktop.org/piglit"
6
7# From 2012/12/30.
8SRCREV = "bbeff5d21b06d37338ad28e42d88f499bef13268"
9# (when PV goes above 1.0 remove the trailing r)
10PV = "1.0+gitr${SRCPV}"
11
12S = "${WORKDIR}/git"
13
14DEPENDS = "virtual/libx11 libxrender waffle virtual/libgl libglu python-mako-native python-numpy-native"
15
16inherit cmake pythonnative
17
18# As piglit doesn't install, enforce in-tree builds so that we can easily copy
19# contents out of $S and $B.
20B="${S}"
21
22# CMake sets the rpath at build time with the source tree, and will reset it at
23# install time. As we don't install this doesn't happen, so force the rpath to
24# what we need.
25EXTRA_OECMAKE = "-DCMAKE_BUILD_WITH_INSTALL_RPATH=1 -DCMAKE_INSTALL_RPATH=${libdir}/piglit/lib"
26
27do_install() {
28 install -d ${D}${bindir}
29 install -m 0755 piglit-*.py ${D}${bindir}
30
31 install -d ${D}${libdir}/piglit/
32
33 install -d ${D}${libdir}/piglit/bin
34 install -m 755 ${S}/bin/* ${D}${libdir}/piglit/bin
35
36 cp -Pr lib/ ${D}${libdir}/piglit/
37 cp -Pr framework/ ${D}${libdir}/piglit/
38 cp -Pr generated_tests/ ${D}${libdir}/piglit/
39 cp -Pr tests/ ${D}${libdir}/piglit/
40 cp -Pr templates/ ${D}${libdir}/piglit/
41
42 sed -i -e 's|sys.path.append(.*)|sys.path.append("${libdir}/piglit")|' ${D}${bindir}/piglit-*.py
43 sed -i -e 's|^templatedir = .*$|templatedir = "${libdir}/piglit/templates"|' ${D}${bindir}/piglit-summary-html.py
44}
45
46FILES_${PN}-dbg += "${libdir}/piglit/*/.debug/"
47
48RDEPENDS_${PN} = "python waffle python-json python-subprocess \
49 python-multiprocessing python-textutils python-netserver python-shell \
50 mesa-demos bash \
51 "