summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/pango/pango_1.44.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/pango/pango_1.44.3.bb')
-rw-r--r--meta/recipes-graphics/pango/pango_1.44.3.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-graphics/pango/pango_1.44.3.bb b/meta/recipes-graphics/pango/pango_1.44.3.bb
new file mode 100644
index 0000000000..1973c63f82
--- /dev/null
+++ b/meta/recipes-graphics/pango/pango_1.44.3.bb
@@ -0,0 +1,46 @@
1SUMMARY = "Framework for layout and rendering of internationalized text"
2DESCRIPTION = "Pango is a library for laying out and rendering of text, \
3with an emphasis on internationalization. Pango can be used anywhere \
4that text layout is needed, though most of the work on Pango so far has \
5been done in the context of the GTK+ widget toolkit. Pango forms the \
6core of text and font handling for GTK+-2.x."
7HOMEPAGE = "http://www.pango.org/"
8BUGTRACKER = "http://bugzilla.gnome.org"
9SECTION = "libs"
10LICENSE = "LGPLv2.0+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
13
14GNOMEBASEBUILDCLASS = "meson"
15
16inherit gnomebase gtk-doc ptest-gnome upstream-version-is-even gobject-introspection
17
18SRC_URI += "file://run-ptest \
19 "
20
21SRC_URI[archive.md5sum] = "7f91f1b5883ff848b445ab11ebabcf03"
22SRC_URI[archive.sha256sum] = "290bb100ca5c7025ec3f97332eaf783b76ba1f444110f06ac5ee3285e3e5aece"
23
24DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi"
25
26PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \
27 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
28
29PACKAGECONFIG[x11] = ",,virtual/libx11 libxft"
30PACKAGECONFIG[tests] = "-Dinstall-tests=true, -Dinstall-tests=false"
31
32GTKDOC_MESON_OPTION = "gtk_doc"
33GIR_MESON_OPTION = 'introspection'
34
35LEAD_SONAME = "libpango-1.0*"
36LIBV = "1.8.0"
37
38FILES_${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
39FILES_${PN}-dev += "${libdir}/pango/${LIBV}/modules/*.la"
40
41RDEPENDS_${PN}-ptest += "liberation-fonts cantarell-fonts"
42
43RPROVIDES_${PN} += "pango-modules pango-module-indic-lang \
44 pango-module-basic-fc pango-module-arabic-lang"
45
46BBCLASSEXTEND = "native nativesdk"