summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/pango/pango_1.40.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/pango/pango_1.40.6.bb')
-rw-r--r--meta/recipes-graphics/pango/pango_1.40.6.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-graphics/pango/pango_1.40.6.bb b/meta/recipes-graphics/pango/pango_1.40.6.bb
new file mode 100644
index 0000000000..31c3d2a658
--- /dev/null
+++ b/meta/recipes-graphics/pango/pango_1.40.6.bb
@@ -0,0 +1,52 @@
1SUMMARY = "Framework for layout and rendering of internationalized text"
2DESCRIPTION = "Pango is a library for laying out and rendering of text, \
3with an emphasis on internationalization. Pango can be used anywhere \
4that text layout is needed, though most of the work on Pango so far has \
5been done in the context of the GTK+ widget toolkit. Pango forms the \
6core of text and font handling for GTK+-2.x."
7HOMEPAGE = "http://www.pango.org/"
8BUGTRACKER = "http://bugzilla.gnome.org"
9SECTION = "libs"
10LICENSE = "LGPLv2.0+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
13
14inherit gnomebase gtk-doc ptest-gnome upstream-version-is-even gobject-introspection
15
16SRC_URI += "file://run-ptest \
17 file://0001-Drop-introspection-macros-from-acinclude.m4.patch \
18 file://0001-Enforce-recreation-of-docs-pango.types-it-is-build-c.patch \
19"
20SRC_URI[archive.md5sum] = "507c6746fbf53fc9d48c577f1e265de3"
21SRC_URI[archive.sha256sum] = "ca152b7383a1e9f7fd74ae96023dc6770dc5043414793bfe768ff06b6759e573"
22
23DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz"
24
25PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
26PACKAGECONFIG[x11] = "--with-xft,--without-xft,virtual/libx11 libxft"
27
28EXTRA_AUTORECONF = ""
29
30EXTRA_OECONF = " \
31 --disable-debug \
32 "
33
34LEAD_SONAME = "libpango-1.0*"
35LIBV = "1.8.0"
36
37# This binary needs to be compiled for the host architecture. This isn't pretty!
38do_compile_prepend_class-target () {
39 if ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'true', 'false', d)}; then
40 make CC="${BUILD_CC}" CFLAGS="" LDFLAGS="${BUILD_LDFLAGS}" AM_CPPFLAGS="$(pkg-config-native --cflags glib-2.0)" gen_all_unicode_LDADD="$(pkg-config-native --libs glib-2.0)" -C ${B}/tests gen-all-unicode
41 fi
42}
43
44FILES_${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
45FILES_${PN}-dev += "${libdir}/pango/${LIBV}/modules/*.la"
46
47RDEPENDS_${PN}-ptest += "liberation-fonts cantarell-fonts"
48
49RPROVIDES_${PN} += "pango-modules pango-module-indic-lang \
50 pango-module-basic-fc pango-module-arabic-lang"
51
52BBCLASSEXTEND = "native"