summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa_git.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa_git.bb b/meta/recipes-graphics/mesa/mesa_git.bb
new file mode 100644
index 0000000000..cda310a525
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa_git.bb
@@ -0,0 +1,23 @@
1require ${BPN}.inc
2
3DEFAULT_PREFERENCE = "-1"
4
5LIC_FILES_CHKSUM = "file://docs/license.html;md5=6a23445982a7a972ac198e93cc1cb3de"
6
7SRCREV = "0028eb1083e6adc110a23a5f02c993cda217067a"
8PV = "10.1.3+git${SRCPV}"
9
10SRC_URI = "git://anongit.freedesktop.org/git/mesa/mesa;branch=10.1 \
11 file://0002-pipe_loader_sw-include-xlib_sw_winsys.h-only-when-HA.patch \
12 file://0006-fix-out-of-tree-egl.patch \
13 "
14
15S = "${WORKDIR}/git"
16
17#because we cannot rely on the fact that all apps will use pkgconfig,
18#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
19do_install_append() {
20 if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
21 sed -i -e 's/^#ifdef MESA_EGL_NO_X11_HEADERS/#if ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
22 fi
23}