summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa_20.0.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa_20.0.7.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa_20.0.7.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa_20.0.7.bb b/meta/recipes-graphics/mesa/mesa_20.0.7.bb
new file mode 100644
index 0000000000..420565808e
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa_20.0.7.bb
@@ -0,0 +1,23 @@
1require ${BPN}.inc
2
3SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
4 file://0001-meson.build-check-for-all-linux-host_os-combinations.patch \
5 file://0002-meson.build-make-TLS-ELF-optional.patch \
6 file://0003-Allow-enable-DRI-without-DRI-drivers.patch \
7 file://0004-Revert-mesa-Enable-asm-unconditionally-now-that-gen_.patch \
8 file://0005-vc4-use-intmax_t-for-formatted-output-of-timespec-me.patch \
9 file://0001-meson-misdetects-64bit-atomics-on-mips-clang.patch \
10 "
11
12SRC_URI[md5sum] = "609cb7664204e031d4c65c602c652a28"
13SRC_URI[sha256sum] = "fe6e258fe772c3cd2ac01741bf7408058c3ac02d66acff9a6e669bd72e3ea178"
14
15UPSTREAM_CHECK_GITTAGREGEX = "mesa-(?P<pver>\d+(\.\d+)+)"
16
17#because we cannot rely on the fact that all apps will use pkgconfig,
18#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
19do_install_append() {
20 if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
21 sed -i -e 's/^#elif defined(__unix__) && defined(EGL_NO_X11)$/#elif defined(__unix__) \&\& defined(EGL_NO_X11) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
22 fi
23}