summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa_19.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa_19.0.0.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa_19.0.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa_19.0.0.bb b/meta/recipes-graphics/mesa/mesa_19.0.0.bb
new file mode 100644
index 0000000000..024acdad0b
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa_19.0.0.bb
@@ -0,0 +1,19 @@
1require ${BPN}.inc
2
3SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
4 file://0001-Simplify-wayland-scanner-lookup.patch \
5 file://0002-winsys-svga-drm-Include-sys-types.h.patch \
6 file://0003-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch \
7 file://0004-use-PKG_CHECK_VAR-for-defining-WAYLAND_PROTOCOLS_DAT.patch \
8"
9
10SRC_URI[md5sum] = "d0d76cd8b00bc1308e37985d4a45d3c5"
11SRC_URI[sha256sum] = "5a549dfb40ec31e5c36c47aadac04554cb2e2a8d144a046a378fc16da57e38f8"
12
13#because we cannot rely on the fact that all apps will use pkgconfig,
14#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
15do_install_append() {
16 if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
17 sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
18 fi
19}