summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa_18.3.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa_18.3.4.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa_18.3.4.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa_18.3.4.bb b/meta/recipes-graphics/mesa/mesa_18.3.4.bb
new file mode 100644
index 0000000000..27f4f0241f
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa_18.3.4.bb
@@ -0,0 +1,20 @@
1require ${BPN}.inc
2
3SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
4 file://0001-Simplify-wayland-scanner-lookup.patch \
5 file://0002-winsys-svga-drm-Include-sys-types.h.patch \
6 file://0003-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch \
7 file://0004-use-PKG_CHECK_VAR-for-defining-WAYLAND_PROTOCOLS_DAT.patch \
8 file://0005-egl-add-missing-include-stddef.h-in-egldevice.h.patch \
9"
10
11SRC_URI[md5sum] = "6f2a5e01dd5cb91d05a9534f5a80c35d"
12SRC_URI[sha256sum] = "32314da4365d37f80d84f599bd9625b00161c273c39600ba63b45002d500bb07"
13
14#because we cannot rely on the fact that all apps will use pkgconfig,
15#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
16do_install_append() {
17 if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
18 sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
19 fi
20}