summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa_17.1.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa_17.1.6.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa_17.1.6.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa_17.1.6.bb b/meta/recipes-graphics/mesa/mesa_17.1.6.bb
new file mode 100644
index 0000000000..64a15e3fb7
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa_17.1.6.bb
@@ -0,0 +1,23 @@
1require ${BPN}.inc
2
3SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
4 file://replace_glibc_check_with_linux.patch \
5 file://disable-asm-on-non-gcc.patch \
6 file://0001-Use-wayland-scanner-in-the-path.patch \
7 file://0002-hardware-gloat.patch \
8 file://vulkan-mkdir.patch \
9 file://llvm-config-version.patch \
10 file://0001-ac-fix-build-after-LLVM-5.0-SVN-r300718.patch \
11 file://0002-gallivm-Fix-build-against-LLVM-SVN-r302589.patch \
12 file://0001-winsys-svga-drm-Include-sys-types.h.patch \
13 "
14SRC_URI[md5sum] = "54758bf842f9ea53c8b57cce4311b87e"
15SRC_URI[sha256sum] = "0686deadde1f126b20aa67e47e8c50502043eee4ecdf60d5009ffda3cebfee50"
16
17#because we cannot rely on the fact that all apps will use pkgconfig,
18#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
19do_install_append() {
20 if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
21 sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
22 fi
23}