summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa_17.1.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa_17.1.5.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa_17.1.5.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa_17.1.5.bb b/meta/recipes-graphics/mesa/mesa_17.1.5.bb
new file mode 100644
index 0000000000..ddfcb371ec
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa_17.1.5.bb
@@ -0,0 +1,20 @@
1require ${BPN}.inc
2
3SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
4 file://replace_glibc_check_with_linux.patch \
5 file://disable-asm-on-non-gcc.patch \
6 file://0001-Use-wayland-scanner-in-the-path.patch \
7 file://0002-hardware-gloat.patch \
8 file://0001-mapi-Only-install-khrplatform.h-with-EGL-or-GLES.patch \
9 file://vulkan-mkdir.patch \
10"
11SRC_URI[md5sum] = "6cf936fbcaadd98924298a7009e8265d"
12SRC_URI[sha256sum] = "378516b171712687aace4c7ea8b37c85895231d7a6d61e1e27362cf6034fded9"
13
14#because we cannot rely on the fact that all apps will use pkgconfig,
15#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
16do_install_append() {
17 if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
18 sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
19 fi
20}