diff options
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa-dri_7.7.bb')
-rw-r--r-- | meta/recipes-graphics/mesa/mesa-dri_7.7.bb | 49 |
1 files changed, 0 insertions, 49 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-dri_7.7.bb b/meta/recipes-graphics/mesa/mesa-dri_7.7.bb deleted file mode 100644 index 4cae9c8699..0000000000 --- a/meta/recipes-graphics/mesa/mesa-dri_7.7.bb +++ /dev/null | |||
@@ -1,49 +0,0 @@ | |||
1 | include mesa-common.inc | ||
2 | |||
3 | SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/7.7/MesaLib-${PV}.tar.bz2 \ | ||
4 | ftp://ftp.freedesktop.org/pub/mesa/7.7/MesaDemos-${PV}.tar.bz2 \ | ||
5 | file://crossfix.patch;patch=1" | ||
6 | |||
7 | PROTO_DEPS = "xf86driproto glproto dri2proto" | ||
8 | LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat" | ||
9 | |||
10 | DEPENDS = "${PROTO_DEPS} ${LIB_DEPS}" | ||
11 | |||
12 | PR = "r12" | ||
13 | |||
14 | # most of our targets do not have DRI so will use mesa-xlib | ||
15 | DEFAULT_PREFERENCE = "-1" | ||
16 | |||
17 | # Atom PCs have DRI support so use mesa-dri by default | ||
18 | DEFAULT_PREFERENCE_atom-pc = "1" | ||
19 | |||
20 | PACKAGES =+ "${PN}-xprogs" | ||
21 | PACKAGES_DYNAMIC = "mesa-dri-driver-*" | ||
22 | |||
23 | FILES_${PN}-dbg += "${libdir}/dri/.debug/*" | ||
24 | FILES_${PN}-xprogs = "${bindir}/glxdemo ${bindir}/glxgears ${bindir}/glxheads ${bindir}/glxinfo" | ||
25 | |||
26 | LEAD_SONAME = "libGL.so.1" | ||
27 | |||
28 | EXTRA_OECONF += "--with-driver=dri --disable-egl --disable-gallium" | ||
29 | |||
30 | do_install_append () { | ||
31 | install -d ${D}/usr/bin | ||
32 | install -m 0755 ${S}/progs/xdemos/{glxdemo,glxgears,glxheads,glxinfo} ${D}/usr/bin/ | ||
33 | } | ||
34 | |||
35 | python populate_packages_prepend() { | ||
36 | import os.path | ||
37 | |||
38 | dri_drivers_root = os.path.join(bb.data.getVar('libdir', d, 1), "dri") | ||
39 | |||
40 | do_split_packages(d, dri_drivers_root, '^(.*)_dri\.so$', 'mesa-dri-driver-%s', 'Mesa %s DRI driver', extra_depends='') | ||
41 | } | ||
42 | |||
43 | COMPATIBLE_HOST = '(i.86.*-linux|x86_64.*-linux)' | ||
44 | |||
45 | |||
46 | # | ||
47 | # Header generated by i586-poky-linux-gcc gen_matypes.c -o gen_matypes -I ../../../include/GL -I ../../../include -I .. -I ../main/ -I ../math -I ../glapi/ -I ../tnl | ||
48 | # then run gen_matypes > matypes.h on device | ||
49 | # | ||