diff options
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa-dri_7.5.bb')
-rw-r--r-- | meta/recipes-graphics/mesa/mesa-dri_7.5.bb | 48 |
1 files changed, 0 insertions, 48 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-dri_7.5.bb b/meta/recipes-graphics/mesa/mesa-dri_7.5.bb deleted file mode 100644 index b50cee8639..0000000000 --- a/meta/recipes-graphics/mesa/mesa-dri_7.5.bb +++ /dev/null | |||
@@ -1,48 +0,0 @@ | |||
1 | include mesa-common.inc | ||
2 | |||
3 | SRC_URI += "file://crossfix.patch;patch=1" | ||
4 | # file://mesa-DRI2Swapbuffer.patch;patch=1 | ||
5 | |||
6 | PROTO_DEPS = "xf86driproto glproto dri2proto" | ||
7 | LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat" | ||
8 | |||
9 | DEPENDS = "${PROTO_DEPS} ${LIB_DEPS}" | ||
10 | |||
11 | PR = "r12" | ||
12 | |||
13 | # most of our targets do not have DRI so will use mesa-xlib | ||
14 | DEFAULT_PREFERENCE = "-1" | ||
15 | |||
16 | # Atom PCs have DRI support so use mesa-dri by default | ||
17 | DEFAULT_PREFERENCE_atom-pc = "1" | ||
18 | |||
19 | PACKAGES =+ "${PN}-xprogs" | ||
20 | PACKAGES_DYNAMIC = "mesa-dri-driver-*" | ||
21 | |||
22 | FILES_${PN}-dbg += "${libdir}/dri/.debug/*" | ||
23 | FILES_${PN}-xprogs = "${bindir}/glxdemo ${bindir}/glxgears ${bindir}/glxheads ${bindir}/glxinfo" | ||
24 | |||
25 | LEAD_SONAME = "libGL.so.1" | ||
26 | |||
27 | EXTRA_OECONF += "--with-driver=dri --disable-egl --disable-gallium" | ||
28 | |||
29 | do_install_append () { | ||
30 | install -d ${D}/usr/bin | ||
31 | install -m 0755 ${S}/progs/xdemos/{glxdemo,glxgears,glxheads,glxinfo} ${D}/usr/bin/ | ||
32 | } | ||
33 | |||
34 | python populate_packages_prepend() { | ||
35 | import os.path | ||
36 | |||
37 | dri_drivers_root = os.path.join(bb.data.getVar('libdir', d, 1), "dri") | ||
38 | |||
39 | do_split_packages(d, dri_drivers_root, '^(.*)_dri\.so$', 'mesa-dri-driver-%s', 'Mesa %s DRI driver', extra_depends='') | ||
40 | } | ||
41 | |||
42 | COMPATIBLE_HOST = '(i.86.*-linux|x86_64.*-linux)' | ||
43 | |||
44 | |||
45 | # | ||
46 | # Header generated by i586-poky-linux-gcc gen_matypes.c -o gen_matypes -I ../../../include/GL -I ../../../include -I .. -I ../main/ -I ../math -I ../glapi/ -I ../tnl | ||
47 | # then run gen_matypes > matypes.h on device | ||
48 | # | ||