summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa-dri_7.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa-dri_7.11.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa-dri_7.11.bb17
1 files changed, 1 insertions, 16 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-dri_7.11.bb b/meta/recipes-graphics/mesa/mesa-dri_7.11.bb
index 5f14346ee1..90873aab48 100644
--- a/meta/recipes-graphics/mesa/mesa-dri_7.11.bb
+++ b/meta/recipes-graphics/mesa/mesa-dri_7.11.bb
@@ -1,22 +1,14 @@
1include mesa-common.inc 1include mesa-common.inc
2include mesa-${PV}.inc
2 3
3PROTO_DEPS = "xf86driproto glproto dri2proto" 4PROTO_DEPS = "xf86driproto glproto dri2proto"
4LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat \ 5LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat \
5 libxml2-native" 6 libxml2-native"
6 7
7DEPENDS = "${PROTO_DEPS} ${LIB_DEPS} makedepend-native python-native" 8DEPENDS = "${PROTO_DEPS} ${LIB_DEPS} makedepend-native python-native"
8DEPENDS += "mesa-dri-glsl-native"
9 9
10PR = "${INC_PR}.0" 10PR = "${INC_PR}.0"
11 11
12SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \
13 file://crossfix.patch \
14 file://uclibc.patch \
15 "
16
17SRC_URI[md5sum] = "ff03aca82d0560009a076a87c888cf13"
18SRC_URI[sha256sum] = "f8bf37a00882840a3e3d327576bc26a79ae7f4e18fe1f7d5f17a5b1c80dd7acf"
19
20# most of our targets do not have DRI so will use mesa-xlib 12# most of our targets do not have DRI so will use mesa-xlib
21DEFAULT_PREFERENCE = "-1" 13DEFAULT_PREFERENCE = "-1"
22 14
@@ -37,10 +29,3 @@ COMPATIBLE_HOST = '(i.86.*-linux|x86_64.*-linux)'
37PACKAGES_DYNAMIC = "mesa-dri-driver-*" 29PACKAGES_DYNAMIC = "mesa-dri-driver-*"
38 30
39FILES_${PN}-dbg += "${libdir}/dri/.debug/*" 31FILES_${PN}-dbg += "${libdir}/dri/.debug/*"
40
41do_configure_prepend() {
42 #check for python not python2, because python-native does not stage python2 binary/link
43 sed -i 's/AC_CHECK_PROGS(\[PYTHON2\], \[python2 python\])/AC_CHECK_PROGS(\[PYTHON2\], \[python python\])/g' ${S}/configure.ac
44 # We need builtin_compiler built for buildhost arch instead of target (is provided by mesa-dri-glsl-native)"
45 sed -i "s#\./builtin_compiler#${STAGING_BINDIR_NATIVE}/glsl/builtin_compiler#g" ${S}/src/glsl/Makefile
46}