summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa-dri-glsl-native_8.0.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa-dri-glsl-native_8.0.4.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa-dri-glsl-native_8.0.4.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-dri-glsl-native_8.0.4.bb b/meta/recipes-graphics/mesa/mesa-dri-glsl-native_8.0.4.bb
new file mode 100644
index 0000000000..a81fb6d035
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa-dri-glsl-native_8.0.4.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "gl shader language specific build from mesa-dri"
2HOMEPAGE = "http://mesa3d.org"
3BUGTRACKER = "https://bugs.freedesktop.org"
4SECTION = "x11"
5LICENSE = "GPLv3+"
6LIC_FILES_CHKSUM = "file://glsl_parser.cpp;beginline=3;endline=33;md5=d078f1cddc2fc355719c090482254bd9"
7
8DEPENDS = "makedepend-native"
9
10SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2"
11SRC_URI[md5sum] = "d546f988adfdf986cff45b1efa2d8a46"
12SRC_URI[sha256sum] = "02ed19f4f5f6535dda03a9932a81438aa78ea723ebba1f39a3d49a70a4e1d07e"
13
14S = "${WORKDIR}/Mesa-${PV}/src/glsl/"
15
16inherit native
17
18# use default config for native build
19do_configure_prepend() {
20 ln -sf ${S}/../../configs/default ${S}/../../configs/current
21}
22
23do_install() {
24 install -d ${D}/${bindir}/glsl
25 install -m 755 ${S}/builtin_compiler ${D}/${bindir}/glsl/builtin_compiler
26 install -m 755 ${S}/glsl_compiler ${D}/${bindir}/glsl/glsl_compiler
27}