summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.8.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.8.2.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.8.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.8.2.bb b/meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.8.2.bb
new file mode 100644
index 0000000000..d6f2c33ea8
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.8.2.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "gl shader language specific build from mesa-dri"
2HOMEPAGE = "http://mesa3d.org"
3BUGTRACKER = "https://bugs.freedesktop.org"
4SECTION = "x11"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://apps/compile.c;endline=26;md5=27c2833286ce9566b162bcbe21d5b267"
7PR = "r0"
8
9DEPENDS = "makedepend-native"
10
11SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2"
12SRC_URI[md5sum] = "6be2d343a0089bfd395ce02aaf8adb57"
13SRC_URI[sha256sum] = "505bf418dceba05837f4ea1b1972b9620c35f8cb94bc4d1e6d573c15f562576d"
14
15S = "${WORKDIR}/Mesa-7.8.2/src/glsl/"
16
17inherit native
18
19# use default config for native build
20do_configure_prepend() {
21 ln -s ${S}/../../configs/default ${S}/../../configs/current
22}
23
24do_install() {
25 install -d ${D}/${bindir}
26 install -m 755 ${S}/apps/compile ${D}/${bindir}/glsl-compile
27}