summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb b/meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb
new file mode 100644
index 0000000000..1caa50bc1b
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb
@@ -0,0 +1,53 @@
1SUMMARY = "Mesa demo applications"
2DESCRIPTION = "This package includes the demonstration application, such as glxgears. \
3These applications can be used for Mesa validation and benchmarking."
4HOMEPAGE = "http://mesa3d.org"
5BUGTRACKER = "https://bugs.freedesktop.org"
6SECTION = "x11"
7
8LICENSE = "MIT & PD"
9LIC_FILES_CHKSUM = "file://src/xdemos/glxgears.c;beginline=1;endline=20;md5=914225785450eff644a86c871d3ae00e \
10 file://src/xdemos/glxdemo.c;beginline=1;endline=8;md5=b01d5ab1aee94d35b7efaa2ef48e1a06"
11
12SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/demos/${PV}/${BPN}-${PV}.tar.bz2 \
13 file://0001-mesa-demos-Add-missing-data-files.patch \
14 file://0002-Correctly-implement-with-AC_WITH-glut-so-that-withou.patch \
15 file://0003-configure-Allow-to-disable-demos-which-require-GLEW-.patch \
16 file://0004-Use-DEMOS_DATA_DIR-to-locate-data-files.patch \
17 file://0005-Fix-build-when-EGL_MESA_screen_surface-extension-isn.patch \
18 file://0006-Query-display-for-EGL_MESA_screen_surface-extension-.patch \
19 file://0007-Install-few-more-test-programs.patch \
20 file://0008-glsl-perf-Add-few-missing-.glsl-.vert-.frag-files-to.patch \
21 file://0009-glsl-perf-Install-.glsl-.vert-.frag-files.patch \
22"
23SRC_URI[md5sum] = "72613a2c8c013716db02e3ff59d29061"
24SRC_URI[sha256sum] = "e4bfecb5816ddd4b7b37c1bc876b63f1f7f06fda5879221a9774d0952f90ba92"
25
26inherit autotools pkgconfig
27
28PACKAGECONFIG ?= "drm osmesa freetype2 gbm egl gles1 gles2 glu \
29 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 glew', '', d)}"
30
31# The Wayland code doesn't work with Wayland 1.0, so disable it for now
32#${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}"
33
34EXTRA_OECONF = "--with-system-data-files"
35
36PACKAGECONFIG[drm] = "--enable-libdrm,--disable-libdrm,libdrm"
37PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl"
38PACKAGECONFIG[freetype2] = "--enable-freetype2,--disable-freetype2,freetype"
39PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm,virtual/libgl"
40PACKAGECONFIG[gles1] = "--enable-gles1,--disable-gles1,virtual/libgles1"
41PACKAGECONFIG[gles2] = "--enable-gles2,--disable-gles2,virtual/libgles2"
42PACKAGECONFIG[glut] = "--with-glut=${STAGING_EXECPREFIXDIR},--without-glut,"
43PACKAGECONFIG[osmesa] = "--enable-osmesa,--disable-osmesa,"
44PACKAGECONFIG[vg] = "--enable-vg,--disable-vg,virtual/libvg"
45PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,virtual/libgl wayland"
46PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11"
47PACKAGECONFIG[glew] = "--enable-glew,--disable-glew,glew"
48PACKAGECONFIG[glu] = "--enable-glu,--disable-glu,virtual/libgl"
49
50do_install_append() {
51 # it can be completely empty when all PACKAGECONFIG options are disabled
52 rmdir --ignore-fail-on-non-empty ${D}${bindir}
53}