summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/libglu_9.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/libglu_9.0.2.bb')
-rw-r--r--meta/recipes-graphics/mesa/libglu_9.0.2.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/libglu_9.0.2.bb b/meta/recipes-graphics/mesa/libglu_9.0.2.bb
new file mode 100644
index 0000000000..ae18f86532
--- /dev/null
+++ b/meta/recipes-graphics/mesa/libglu_9.0.2.bb
@@ -0,0 +1,28 @@
1SUMMARY = "The OpenGL utility toolkit"
2DESCRIPTION = "GLU is a utility toolkit used with OpenGL implementations"
3
4HOMEPAGE = "http://mesa3d.org"
5BUGTRACKER = "https://bugs.freedesktop.org"
6SECTION = "x11"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://include/GL/glu.h;endline=29;md5=6b79c570f644363b356456e7d44471d9 \
9 file://src/libtess/tess.c;endline=29;md5=6b79c570f644363b356456e7d44471d9"
10
11# Epoch as this used to be part of mesa
12PE = "2"
13
14SRC_URI = "https://mesa.freedesktop.org/archive/glu/glu-${PV}.tar.gz"
15
16SRC_URI[sha256sum] = "24effdfb952453cc00e275e1c82ca9787506aba0282145fff054498e60e19a65"
17
18S = "${WORKDIR}/glu-${PV}"
19
20DEPENDS = "virtual/libgl"
21
22inherit autotools pkgconfig features_check
23
24# Requires libGL.so which is provided by mesa when x11 in DISTRO_FEATURES
25REQUIRED_DISTRO_FEATURES = "x11 opengl"
26
27# Remove the mesa-glu dependency in mesa-glu-dev, as mesa-glu is empty
28RDEPENDS_${PN}-dev = ""