summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/matchbox-wm/matchbox-wm_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/matchbox-wm/matchbox-wm_svn.bb')
-rw-r--r--meta/recipes-graphics/matchbox-wm/matchbox-wm_svn.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-graphics/matchbox-wm/matchbox-wm_svn.bb b/meta/recipes-graphics/matchbox-wm/matchbox-wm_svn.bb
new file mode 100644
index 0000000000..09c0f70f47
--- /dev/null
+++ b/meta/recipes-graphics/matchbox-wm/matchbox-wm_svn.bb
@@ -0,0 +1,44 @@
1DESCRIPTION = "Matchbox window manager"
2HOMEPAGE = "http://matchbox-project.org"
3BUGTRACKER = "http://bugzilla.openedhand.com/"
4
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://src/wm.h;endline=21;md5=a7e844465edbcf79c282369f93caa835 \
7 file://src/main.c;endline=21;md5=3e5d9f832b527b0d72dbe8e3c4c60b95 \
8 file://src/wm.c;endline=21;md5=8dc9d24477d87ef5dfbc2e4927146aab"
9
10SECTION = "x11/wm"
11DEPENDS = "libmatchbox virtual/libx11 libxext libxrender startup-notification expat gconf"
12
13PV = "1.2+svnr${SRCREV}"
14PR = "r4"
15
16SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-window-manager;proto=http \
17 file://configure_fix.patch;patch=1;maxrev=1818 \
18 file://kbdconfig"
19
20S = "${WORKDIR}/matchbox-window-manager"
21
22inherit autotools pkgconfig update-alternatives
23
24ALTERNATIVE_NAME = "x-session-manager"
25ALTERNATIVE_LINK = "${bindir}/x-session-manager"
26ALTERNATIVE_PATH = "${bindir}/matchbox-session"
27ALTERNATIVE_PRIORITY = "10"
28
29FILES_${PN} = "${bindir}/* \
30 ${datadir}/matchbox \
31 ${sysconfdir}/matchbox \
32 ${datadir}/themes/blondie/matchbox \
33 ${datadir}/themes/Default/matchbox \
34 ${datadir}/themes/MBOpus/matchbox"
35
36EXTRA_OECONF = " --enable-startup-notification \
37 --disable-xrm \
38 --enable-expat \
39 --with-expat-lib=${STAGING_LIBDIR} \
40 --with-expat-includes=${STAGING_INCDIR}"
41
42do_install_prepend() {
43 install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
44}