summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/matchbox-wm/matchbox-wm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/matchbox-wm/matchbox-wm_git.bb')
-rw-r--r--meta/recipes-graphics/matchbox-wm/matchbox-wm_git.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-graphics/matchbox-wm/matchbox-wm_git.bb b/meta/recipes-graphics/matchbox-wm/matchbox-wm_git.bb
new file mode 100644
index 0000000000..154b967d2c
--- /dev/null
+++ b/meta/recipes-graphics/matchbox-wm/matchbox-wm_git.bb
@@ -0,0 +1,38 @@
1SUMMARY = "Matchbox lightweight window manager"
2HOMEPAGE = "http://matchbox-project.org"
3BUGTRACKER = "http://bugzilla.yoctoproject.org/"
4
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://src/wm.h;endline=21;md5=a7e844465edbcf79c282369f93caa835 \
7 file://src/main.c;endline=21;md5=3e5d9f832b527b0d72dbe8e3c4c60b95 \
8 file://src/wm.c;endline=21;md5=8dc9d24477d87ef5dfbc2e4927146aab"
9
10SECTION = "x11/wm"
11DEPENDS = "libmatchbox virtual/libx11 libxext libxrender startup-notification expat gconf libxcursor libxfixes"
12
13SRCREV = "29544f0e61cc281fc60061443a537271e1081b78"
14PV = "1.2+git${SRCPV}"
15
16SRC_URI = "git://git.yoctoproject.org/matchbox-window-manager \
17 file://kbdconfig"
18
19S = "${WORKDIR}/git"
20
21inherit autotools pkgconfig
22
23FILES_${PN} = "${bindir}/* \
24 ${datadir}/matchbox \
25 ${sysconfdir}/matchbox \
26 ${datadir}/themes/blondie/matchbox \
27 ${datadir}/themes/Default/matchbox \
28 ${datadir}/themes/MBOpus/matchbox"
29
30EXTRA_OECONF = " --enable-startup-notification \
31 --disable-xrm \
32 --enable-expat \
33 --with-expat-lib=${STAGING_LIBDIR} \
34 --with-expat-includes=${STAGING_INCDIR}"
35
36do_install_prepend() {
37 install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
38}