summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.bb')
-rw-r--r--meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.bb b/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.bb
new file mode 100644
index 0000000000..8ee42c34b0
--- /dev/null
+++ b/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Matchbox lightweight window manager"
2SECTION = "x11/wm"
3LICENSE = "GPLv2.0+"
4DEPENDS = "libmatchbox virtual/libx11 libxext libxcomposite libxfixes libxcursor xdamage libxrender startup-notification expat"
5PR = "r5"
6
7SRC_URI = "http://downloads.yoctoproject.org/releases/matchbox/matchbox-window-manager/${PV}/matchbox-window-manager-${PV}.tar.bz2 \
8 file://configure_fix.patch \
9 file://kbdconfig \
10 file://gconf-2.m4"
11
12SRC_URI[md5sum] = "3e158dcf57823b55c926d95b245500fb"
13SRC_URI[sha256sum] = "81a23a4af797cf350759fd5ac738797015a66dd5dba2f3d9f3c6908506c1ceff"
14
15S = "${WORKDIR}/matchbox-window-manager-${PV}"
16
17inherit autotools pkgconfig
18
19FILES_${PN} = "${bindir}/* \
20 ${datadir}/matchbox \
21 ${sysconfdir}/matchbox \
22 ${datadir}/themes/blondie/matchbox \
23 ${datadir}/themes/Default/matchbox \
24 ${datadir}/themes/MBOpus/matchbox"
25
26EXTRA_OECONF = " --enable-startup-notification \
27 --disable-xrm \
28 --enable-expat \
29 --with-expat-lib=${STAGING_LIBDIR} \
30 --with-expat-includes=${STAGING_INCDIR}"
31
32
33do_configure_prepend () {
34 cp ${WORKDIR}/gconf-2.m4 ${S}/
35}
36
37do_install_prepend() {
38 install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
39}