summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.bb')
-rw-r--r--meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.bb b/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.bb
new file mode 100644
index 0000000000..f68eb2b4ae
--- /dev/null
+++ b/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.bb
@@ -0,0 +1,41 @@
1SECTION = "x11/wm"
2DESCRIPTION = "Matchbox window manager"
3LICENSE = "GPL"
4DEPENDS = "libmatchbox virtual/libx11 libxext libxcomposite libxfixes xdamage libxrender startup-notification expat"
5PR = "r4"
6
7SRC_URI = "http://matchbox-project.org/sources/matchbox-window-manager/1.2/matchbox-window-manager-${PV}.tar.bz2 \
8 file://configure_fix.patch;patch=1 \
9 file://kbdconfig \
10 file://gconf-2.m4"
11
12S = "${WORKDIR}/matchbox-window-manager-${PV}"
13
14inherit autotools pkgconfig update-alternatives
15
16FILES_${PN} = "${bindir}/* \
17 ${datadir}/matchbox \
18 ${sysconfdir}/matchbox \
19 ${datadir}/themes/blondie/matchbox \
20 ${datadir}/themes/Default/matchbox \
21 ${datadir}/themes/MBOpus/matchbox"
22
23ALTERNATIVE_NAME = "x-session-manager"
24ALTERNATIVE_LINK = "${bindir}/x-session-manager"
25ALTERNATIVE_PATH = "${bindir}/matchbox-session"
26ALTERNATIVE_PRIORITY = "10"
27
28EXTRA_OECONF = " --enable-startup-notification \
29 --disable-xrm \
30 --enable-expat \
31 --with-expat-lib=${STAGING_LIBDIR} \
32 --with-expat-includes=${STAGING_INCDIR}"
33
34
35do_configure_prepend () {
36 cp ${WORKDIR}/gconf-2.m4 ${S}/
37}
38
39do_install_prepend() {
40 install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
41}