summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/matchbox-wm/matchbox-wm_1.1.bb')
-rw-r--r--meta/recipes-graphics/matchbox-wm/matchbox-wm_1.1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.1.bb b/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.1.bb
new file mode 100644
index 0000000000..ebed31e2a5
--- /dev/null
+++ b/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.1.bb
@@ -0,0 +1,37 @@
1SECTION = "x11/wm"
2DESCRIPTION = "Matchbox window manager"
3LICENSE = "GPL"
4DEPENDS = "libmatchbox virtual/libx11 libxext libxcomposite libxfixes xdamage libxrender startup-notification expat"
5PR="r4"
6
7
8SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-window-manager/1.1/matchbox-window-manager-${PV}.tar.gz \
9 file://kbdconfig \
10 file://gconf-2.m4"
11
12S = "${WORKDIR}/matchbox-window-manager-${PV}"
13
14inherit autotools pkgconfig update-alternatives
15
16FILES_${PN} = "${bindir}/* \
17 ${datadir}/matchbox \
18 ${sysconfdir}/matchbox \
19 ${datadir}/themes/blondie/matchbox \
20 ${datadir}/themes/Default/matchbox \
21 ${datadir}/themes/MBOpus/matchbox"
22
23ALTERNATIVE_NAME = "x-session-manager"
24ALTERNATIVE_LINK = "${bindir}/x-session-manager"
25ALTERNATIVE_PATH = "${bindir}/matchbox-session"
26ALTERNATIVE_PRIORITY = "10"
27
28EXTRA_OECONF = " --enable-startup-notification --disable-xrm"
29
30do_configure_prepend () {
31 cp ${WORKDIR}/gconf-2.m4 ${S}/
32}
33
34do_install_prepend() {
35 install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
36}
37